CVE-2025-48912
CVE-2025-48912 · Apache Superset: Improper authorization bypass on row level security via SQL Injection
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
CVSS 7.1 · Hoch · EPSS 0,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
apache superset
- Softwareversionen
- ≥ 0, < 4.1.2: Betroffen (semver)
Auf 4.1.2 aktualisieren
apache-superset PyPI
- Softwareversionen
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- 2.1.2
- 2.1.3
- 3.0.0
- 3.0.0rc1
- 3.0.0rc2
- 3.0.0rc3
- 3.0.0rc4
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.1.0
- 3.1.0rc1
- 3.1.0rc2
- 3.1.0rc3
- 3.1.0rc4
- 3.1.1
- 3.1.2
- 3.1.3
- 4.0.0
- 4.0.0rc1
- 4.0.0rc2
- 4.0.1
- 4.0.2
- 4.1.0
- 4.1.0rc2
- 4.1.0rc3
- 4.1.0rc4
- 4.1.1
- 4.1.1rc1
- 4.1.2rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.2
Auf 4.1.2 aktualisieren