CVE-2025-49844
CVE-2025-49844 · Redis Lua Use-After-Free may lead to remote code execution
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate the garbage collector, trigger a use-after-free and potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.
CVSS 10.0 · Kritisch · EPSS 82,6% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · database
Betroffene Produkte und Versionen
redis
- Softwareversionen
- < 8.2.2: Betroffen
Keine Korrektur veröffentlicht
redict Debian:14
- Softwareversionen
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- 7.3.1+ds-1
- 7.3.2+ds-1
- 7.3.2+ds-1~bpo12+1
- 7.3.5+ds-1
- 7.3.5+ds-1~bpo12+1
- 7.3.6+ds-1~bpo12+1
- 7.3.6+ds-1~bpo13+1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.3.6+ds-1
Auf 7.3.6+ds-1 aktualisieren
redis Debian:12
- Softwareversionen
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1~deb12u1
- 5:7.0.15-1~deb12u2
- 5:7.0.15-1~deb12u3
- 5:7.0.15-1~deb12u4
- 5:7.0.15-1~deb12u5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:7.0.15-1~deb12u6
Auf 5:7.0.15-1~deb12u6 aktualisieren
redis Debian:13
- Softwareversionen
- 5:8.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:8.0.2-3+deb13u1
Auf 5:8.0.2-3+deb13u1 aktualisieren
redis Debian:14
- Softwareversionen
- 5:8.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:8.0.4-1
Auf 5:8.0.4-1 aktualisieren
valkey Debian:13
- Softwareversionen
- 8.1.1+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.1+dfsg1-3+deb13u1
Auf 8.1.1+dfsg1-3+deb13u1 aktualisieren
valkey Debian:14
- Softwareversionen
- 8.1.1+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.4+dfsg1-1
Auf 8.1.4+dfsg1-1 aktualisieren
lua5.1 Ubuntu:14.04:LTS
- Softwareversionen
- 5.1.5-5
- 5.1.5-5ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- 2:2.8.4-2ubuntu0.2+esm2
- 2:2.8.4-2ubuntu0.2+esm3
- 2:2.8.4-2ubuntu0.2+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:2.8.4-2ubuntu0.2+esm5
Auf 2:2.8.4-2ubuntu0.2+esm5 aktualisieren
redis Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- 2:3.0.6-1ubuntu0.4+esm1
- 2:3.0.6-1ubuntu0.4+esm2
- 2:3.0.6-1ubuntu0.4+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:3.0.6-1ubuntu0.4+esm4
Auf 2:3.0.6-1ubuntu0.4+esm4 aktualisieren
lua50 Ubuntu:16.04:LTS
- Softwareversionen
- 5.0.3-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
lua5.1 Ubuntu:18.04:LTS
- Softwareversionen
- 5.1.5-8.1build1
- 5.1.5-8.1build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
lua50 Ubuntu:18.04:LTS
- Softwareversionen
- 5.0.3-8
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- 5:4.0.9-1ubuntu0.2+esm3
- 5:4.0.9-1ubuntu0.2+esm4
- 5:4.0.9-1ubuntu0.2+esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm6
Auf 5:4.0.9-1ubuntu0.2+esm6 aktualisieren
lua5.1 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 5.1.5-8.1build3
- 5.1.5-8.1build4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.1.5-8.1ubuntu0.20.04.1~esm1
Auf 5.1.5-8.1ubuntu0.20.04.1~esm1 aktualisieren
lua50 Ubuntu:20.04:LTS
- Softwareversionen
- 5.0.3-8build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- 5:5.0.7-2ubuntu0.1+esm1
- 5:5.0.7-2ubuntu0.1+esm2
- 5:5.0.7-2ubuntu0.1+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm4
Auf 5:5.0.7-2ubuntu0.1+esm4 aktualisieren
lua5.1 Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 5.1.5-8.1build4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.1.5-8.1ubuntu0.22.04.1~esm1
Auf 5.1.5-8.1ubuntu0.22.04.1~esm1 aktualisieren
lua5.1 Ubuntu:24.04:LTS
- Softwareversionen
- 5.1.5-9
- 5.1.5-9build1
- 5.1.5-9build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:24.04:LTS
- Softwareversionen
- 5:7.0.12-1
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1
- 5:7.0.15-1build1
- 5:7.0.15-1build2
- 5:7.0.15-1ubuntu0.24.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:7.0.15-1ubuntu0.24.04.2
Auf 5:7.0.15-1ubuntu0.24.04.2 aktualisieren
valkey Ubuntu:24.04:LTS
- Softwareversionen
- 7.2.5+dfsg1-2ubuntu4~24.04.1
- 7.2.7+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.2
- 7.2.8+dfsg1-0ubuntu0.24.04.3
- 7.2.10+dfsg1-0ubuntu0.1
- 7.2.11+dfsg1-0ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.2.11+dfsg1-0ubuntu0.2
Auf 7.2.11+dfsg1-0ubuntu0.2 aktualisieren
lua5.1 Ubuntu:25.10
- Softwareversionen
- 5.1.5-11
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redict Ubuntu:25.10
- Softwareversionen
- 7.3.2+ds-1
- 7.3.5+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.3.5+ds-1ubuntu0.1
Auf 7.3.5+ds-1ubuntu0.1 aktualisieren
redis Ubuntu:25.10
- Softwareversionen
- 5:7.0.15-3
- 5:7.0.15-3.1
- 5:8.0.2-3
- 5:8.0.2-3build1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:8.0.2-3ubuntu0.25.10.1
Auf 5:8.0.2-3ubuntu0.25.10.1 aktualisieren
Originalquellen
- https://github.com/redis/redis/security/advisories/GHSA-4789-qfc9-5f9q
- https://github.com/redis/redis/commit/d5728cb5795c966c5b5b1e0f0ac576a7e69af539
- https://github.com/redis/redis/releases/tag/8.2.2
- https://github.com/lastvocher/redis-CVE-2025-49844
- http://www.openwall.com/lists/oss-security/2025/10/07/2
- https://nvd.nist.gov/vuln/detail/CVE-2025-49844