CVE-2025-53368
CVE-2025-53368 · Citizen is vulnerable to stored XSS attack in the legacy search bar
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. From versions 1.9.4 to before 3.4.0, page descriptions are inserted into raw HTML without proper sanitization by the Citizen skin when using the old search bar. Any user with page editing privileges can insert cross-site scripting (XSS) payloads into the DOM for other users who are searching for specific pages. This issue has been patched in version 3.4.0.
CVSS 8.6 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: php
Betroffene Produkte und Versionen
mediawiki-skins-citizen
- Softwareversionen
- >= 1.9.4, < 3.4.0: Betroffen
- >= b2bd79196db1153d0bc1bd51a646d957cbdf4aec, < aedbceb3380bb48db6b59e272fc187529c71c8ca: Betroffen
Keine Korrektur veröffentlicht
starcitizentools/citizen-skin Packagist
- Softwareversionen
- v1.10.0
- v1.13.0
- v1.14.0
- v1.14.1
- v1.15.0
- v1.16.0
- v1.16.1
- v1.17.0
- v1.17.1
- v1.17.2
- v1.17.3
- v1.17.4
- v1.17.5
- v1.17.6
- v1.17.7
- v1.17.8
- v1.17.9
- v1.9.4
- v1.9.5
- v2.0.0
- v2.0.0-alpha.0
- v2.0.0-alpha.1
- v2.0.0-alpha.2
- v2.0.0-beta.0
- v2.0.0-beta.1
- v2.0.0-beta.2
- v2.0.0-beta.3
- v2.0.0-beta.4
- v2.0.1
- v2.1.0
- v2.10.0
- v2.10.1
- v2.11.0
- v2.11.1
- v2.12.0
- v2.13.0
- v2.13.1
- v2.13.2
- v2.13.3
- v2.13.4
- v2.13.5
- v2.14.0
- v2.14.1
- v2.15.0
- v2.15.1
- v2.16.0
- v2.16.1
- v2.17.0
- v2.17.1
- v2.17.2
- v2.18.0
- v2.18.1
- v2.19.0
- v2.2.0
- v2.20.0
- v2.21.0
- v2.22.0
- v2.22.1
- v2.23.0
- v2.24.0
- v2.25.0
- v2.26.0
- v2.27.0
- v2.28.0
- v2.29.0
- v2.3.0
- v2.3.1
- v2.3.2
- v2.3.3
- v2.3.4
- v2.3.5
- v2.3.6
- v2.30.0
- v2.31.0
- v2.32.0
- v2.33.0
- v2.34.0
- v2.35.0
- v2.36.0
- v2.37.0
- v2.38.0
- v2.38.1
- v2.38.2
- v2.38.3
- v2.39.0
- v2.39.1
- v2.39.2
- v2.39.3
- v2.39.4
- v2.4.0
- v2.4.1
- v2.4.2
- v2.4.3
- v2.4.4
- v2.40.0
- v2.40.1
- v2.40.2
- v2.5.0
- v2.5.1
- v2.5.2
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- v2.6.6
- v2.7.0
- v2.7.1
- v2.7.10
- v2.7.11
- v2.7.2
- v2.7.3
- v2.7.4
- v2.7.5
- v2.7.6
- v2.7.7
- v2.7.8
- v2.7.9
- v2.8.0
- v2.8.1
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.9.0
- v2.9.1
- v3.0.0
- v3.1.0
- v3.2.0
- v3.3.0
- v3.3.1
- v3.3.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.9.4, < 3.4.0
Auf 3.4.0 aktualisieren
Originalquellen
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-rq6g-6g94-jfr4
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/aedbceb3380bb48db6b59e272fc187529c71c8ca
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/releases/tag/v3.4.0
- https://nvd.nist.gov/vuln/detail/CVE-2025-53368