p PatchFirst

CVE-2025-54073

CVE-2025-54073 · mcp-package-docs vulnerable to command injection in several tools

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

mcp-package-docs is an MCP (Model Context Protocol) server that provides LLMs with efficient access to package documentation across multiple programming languages and language server protocol (LSP) capabilities. A command injection vulnerability exists in the `mcp-package-docs` MCP Server prior to the fix in commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `>`, `&&`, etc.). Commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9 in version 0.1.27 contains a fix for the issue, but upgrading to 0.1.28 is recommended.

CVSS 7.5 · Hoch · EPSS 11,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • mcp-package-docs

    Softwareversionen
    • < 0.1.27: Betroffen

    Keine Korrektur veröffentlicht

  • mcp-package-docs npm

    Betroffene Versionsbereiche
    • SEMVER: < 0.1.28

    Auf 0.1.28 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →