p PatchFirst

CVE-2025-54370

CVE-2025-54370 · PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.

CVSS 8.7 · Hoch · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • phpspreadsheet

    Softwareversionen
    • < 1.30.0: Betroffen
    • >= 2.0.0, < 2.1.12: Betroffen
    • >= 2.2.0, < 2.4.0: Betroffen
    • >= 3.0.0, < 3.10.0: Betroffen
    • >= 4.0.0, < 5.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • phpoffice/phpspreadsheet Packagist

    Softwareversionen
    • 1.0.0
    • 1.0.0-beta
    • 1.0.0-beta2
    • 1.1.0
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.12.0
    • 1.13.0
    • 1.14.0
    • 1.14.1
    • 1.15.0
    • 1.16.0
    • 1.17.0
    • 1.17.1
    • 1.18.0
    • 1.19.0
    • 1.2.0
    • 1.2.1
    • 1.20.0
    • 1.21.0
    • 1.22.0
    • 1.23.0
    • 1.24.0
    • 1.24.1
    • 1.25.0
    • 1.25.1
    • 1.25.2
    • 1.26.0
    • 1.27.0
    • 1.27.1
    • 1.28.0
    • 1.29.0
    • 1.29.1
    • 1.29.10
    • 1.29.11
    • 1.29.12
    • 1.29.2
    • 1.29.4
    • 1.29.5
    • 1.29.6
    • 1.29.7
    • 1.29.8
    • 1.29.9
    • 1.3.0
    • 1.3.1
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    • 1.8.2
    • 1.9.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.30.0

    Auf 1.30.0 aktualisieren

  • phpoffice/phpspreadsheet Packagist

    Softwareversionen
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.1.10
    • 2.1.11
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.0.0, < 2.1.12

    Auf 2.1.12 aktualisieren

  • phpoffice/phpspreadsheet Packagist

    Softwareversionen
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.10
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.3.6
    • 2.3.7
    • 2.3.8
    • 2.3.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.2.0, < 2.4.0

    Auf 2.4.0 aktualisieren

  • phpoffice/phpspreadsheet Packagist

    Softwareversionen
    • 3.3.0
    • 3.4.0
    • 3.5.0
    • 3.6.0
    • 3.7.0
    • 3.8.0
    • 3.9.0
    • 3.9.1
    • 3.9.2
    • 3.9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.0.0, < 3.10.0

    Auf 3.10.0 aktualisieren

  • phpoffice/phpspreadsheet Packagist

    Softwareversionen
    • 4.0.0
    • 4.1.0
    • 4.2.0
    • 4.3.0
    • 4.3.1
    • 4.4.0
    • 4.5.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.0.0, < 5.0.0

    Auf 5.0.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →