CVE-2025-55193
CVE-2025-55193 · Active Record logging vulnerable to ANSI escape injection
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Active Record connects classes to relational database tables. Prior to versions 7.1.5.2, 7.2.2.2, and 8.0.2.1, the ID passed to find or similar methods may be logged without escaping. If this is directly to the terminal it may include unescaped ANSI sequences. This issue has been patched in versions 7.1.5.2, 7.2.2.2, and 8.0.2.1.
CVSS 2.7 · Niedrig · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
rails
- Softwareversionen
- >= 0, < 7.1.5.2: Betroffen
- >= 7.2, < 7.2.2.2: Betroffen
- >= 8.0, < 8.0.2.1: Betroffen
Keine Korrektur veröffentlicht
rails Debian:12
- Softwareversionen
- 2:6.1.7.10+dfsg-1~deb12u1
- 2:6.1.7.3+dfsg-1
- 2:6.1.7.3+dfsg-10
- 2:6.1.7.3+dfsg-11
- 2:6.1.7.3+dfsg-12
- 2:6.1.7.3+dfsg-13
- 2:6.1.7.3+dfsg-2
- 2:6.1.7.3+dfsg-2~deb12u1
- 2:6.1.7.3+dfsg-3
- 2:6.1.7.3+dfsg-4
- 2:6.1.7.3+dfsg-5
- 2:6.1.7.3+dfsg-6
- 2:6.1.7.3+dfsg-7
- 2:6.1.7.3+dfsg-7~exp1
- 2:6.1.7.3+dfsg-8
- 2:6.1.7.3+dfsg-9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:6.1.7.10+dfsg-1~deb12u2
Auf 2:6.1.7.10+dfsg-1~deb12u2 aktualisieren
rails Debian:13
- Softwareversionen
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:7.2.2.2+dfsg-2~deb13u1
Auf 2:7.2.2.2+dfsg-2~deb13u1 aktualisieren
rails Debian:14
- Softwareversionen
- 2:7.2.2.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:7.2.2.2+dfsg-1
Auf 2:7.2.2.2+dfsg-1 aktualisieren
rails Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:24.04:LTS
- Softwareversionen
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:25.10
- Softwareversionen
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:26.10
- Softwareversionen
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:26.04:LTS
- Softwareversionen
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/rails/rails/security/advisories/GHSA-76r7-hhxj-r776
- https://github.com/rails/rails/commit/3beef20013736fd52c5dcfdf061f7999ba318290
- https://github.com/rails/rails/commit/568c0bc2f1e74c65d150a84b89a080949bf9eb9b
- https://github.com/rails/rails/commit/6a944ca4805e72050a0fbb1a461534eb760d3202
- https://nvd.nist.gov/vuln/detail/CVE-2025-55193