p PatchFirst

CVE-2025-57804

CVE-2025-57804 · h2 allows HTTP Request Smuggling due to illegal characters in headers

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

h2 is a pure-Python implementation of a HTTP/2 protocol stack. Prior to version 4.3.0, an HTTP/2 request splitting vulnerability allows attackers to perform request smuggling attacks by injecting CRLF characters into headers. This occurs when servers downgrade HTTP/2 requests to HTTP/1.1 without properly validating header names/values, enabling attackers to manipulate request boundaries and bypass security controls. This issue has been patched in version 4.3.0.

CVSS 6.9 · Mittel · EPSS 1,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • h2

    Softwareversionen
    • < 4.3.0: Betroffen

    Keine Korrektur veröffentlicht

  • python-h2 Debian:12

    Softwareversionen
    • 4.1.0-4
    • 4.2.0-1
    • 4.3.0-1
    • 4.3.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-h2 Debian:13

    Softwareversionen
    • 4.2.0-1
    • 4.3.0-1
    • 4.3.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-h2 Debian:14

    Softwareversionen
    • 4.2.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.3.0-1

    Auf 4.3.0-1 aktualisieren

  • h2 PyPI

    Softwareversionen
    • 0.1.0
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 3.0.0
    • 3.0.1
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 4.0.0
    • 4.1.0
    • 4.2.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.3.0

    Auf 4.3.0 aktualisieren

  • python-h2 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.0.1-1
    • 3.0.1-2
    • 3.0.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-h2 Ubuntu:20.04:LTS

    Softwareversionen
    • 3.0.1-4
    • 3.0.1-4.1ubuntu1
    • 3.0.1-5
    • 3.1.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-h2 Ubuntu:22.04:LTS

    Softwareversionen
    • 4.0.0-3
    • 4.1.0-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-h2 Ubuntu:24.04:LTS

    Softwareversionen
    • 4.1.0-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-h2 Ubuntu:25.10

    Softwareversionen
    • 4.1.0-4
    • 4.2.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-h2 Ubuntu:26.04:LTS

    Softwareversionen
    • 4.2.0-1
    • 4.3.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →