CVE-2025-59420
CVE-2025-59420 · Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.4, Authlib’s JWS verification accepts tokens that declare unknown critical header parameters (crit), violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header (for example, bork or cnf) that strict verifiers reject but Authlib accepts. In mixed‑language fleets, this enables split‑brain verification and can lead to policy bypass, replay, or privilege escalation. This issue has been patched in version 1.6.4.
CVSS 7.5 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
authlib
- Softwareversionen
- < 1.6.4: Betroffen
Keine Korrektur veröffentlicht
python-authlib Debian:12
- Softwareversionen
- 1.2.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.2.0-1+deb12u1
Auf 1.2.0-1+deb12u1 aktualisieren
python-authlib Debian:13
- Softwareversionen
- 1.6.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.0-1+deb13u1
Auf 1.6.0-1+deb13u1 aktualisieren
python-authlib Debian:14
- Softwareversionen
- 1.6.0-1
- 1.6.1-1
- 1.6.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.4-1
Auf 1.6.4-1 aktualisieren
authlib PyPI
- Softwareversionen
- 0.1
- 0.10
- 0.11
- 0.12
- 0.12.1
- 0.13
- 0.14
- 0.14.1
- 0.14.2
- 0.14.3
- 0.15
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.1rc0
- 0.2
- 0.2.1
- 0.3
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.7
- 0.8
- 0.9
- 1.0.0
- 1.0.0a1
- 1.0.0a2
- 1.0.0b1
- 1.0.0b2
- 1.0.0rc1
- 1.0.1
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.4
Auf 1.6.4 aktualisieren
python-authlib Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.15.4-1
- 0.15.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.15.5-1ubuntu0.1~esm1
Auf 0.15.5-1ubuntu0.1~esm1 aktualisieren
python-authlib Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 1.2.1-1
- 1.3.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.3.0-1ubuntu0.1~esm1
Auf 1.3.0-1ubuntu0.1~esm1 aktualisieren
python-authlib Ubuntu:25.10
- Softwareversionen
- 1.5.1-1
- 1.5.2-1
- 1.6.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-authlib Ubuntu:26.10
- Softwareversionen
- 1.6.7-1
- 1.7.2-1
- 1.7.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-authlib Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 1.6.0-1
- 1.6.5-1
- 1.6.6-1
- 1.6.7-1
- 1.6.7-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht