CVE-2025-59840
CVE-2025-59840 · Vega Cross-Site Scripting (XSS) via expressions abusing toString calls in environments using the VEGA_DEBUG global variable
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. They are vulnerable if they use `vega` in an application that attaches `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window` and if they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). Patches are available in the following Vega applications. If using the latest Vega line (6.x), upgrade to `vega` `6.2.0` / `vega-expression` `6.1.0` / `vega-interpreter` `2.2.1` (if using AST evaluator mode). If using Vega in a non-ESM environment, upgrade to `vega-expression` `5.2.1` / `1.2.1` (if using AST evaluator mode). Some workarounds are available. Do not attach `vega` View instances to global variables, and do not attach `vega` to the global window. These practices of attaching the vega library and View instances may be convenient for debugging, but should not be used in production or in any situation where vega/vega-lite definitions could be provided by untrusted parties.
CVSS 8.1 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
vega
- Softwareversionen
- vega < 6.2.0: Betroffen
- vega-expression >= 6.0.0, < 6.1.0: Betroffen
- vega-expression < 5.2.1: Betroffen
- vega-interpreter >= 2.0.0, < 2.2.1: Betroffen
- vega-interpreter < 1.2.1: Betroffen
Keine Korrektur veröffentlicht
vega.js Debian:12
- Softwareversionen
- 5.22.1+ds+~3.1.0-4
- 5.25.0+ds+~cs5.3.0-1
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-3
- 5.25.0+ds+~cs5.3.0-4
- 5.25.0+ds+~cs5.3.0-5
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
vega.js Debian:13
- Softwareversionen
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
vega.js Debian:14
- Softwareversionen
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.33.1+ds+~cs5.3.0-4
Auf 5.33.1+ds+~cs5.3.0-4 aktualisieren
vega npm
- Betroffene Versionsbereiche
- SEMVER: < 6.2.0
Auf 6.2.0 aktualisieren
vega-expression npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 6.0.0, < 6.1.0
Auf 6.1.0 aktualisieren
vega-interpreter npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.0.0, < 2.2.1
Auf 2.2.1 aktualisieren
vega-interpreter npm
- Betroffene Versionsbereiche
- SEMVER: < 1.2.1
Auf 1.2.1 aktualisieren
vega-expression npm
- Betroffene Versionsbereiche
- SEMVER: < 5.2.1
Auf 5.2.1 aktualisieren
vega.js Ubuntu:24.04:LTS
- Softwareversionen
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
vega.js Ubuntu:25.10
- Softwareversionen
- 5.28.0+ds+~cs5.3.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
vega.js Ubuntu:26.10
- Softwareversionen
- 5.28.0+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
vega.js Ubuntu:26.04:LTS
- Softwareversionen
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht