CVE-2025-61594
CVE-2025-61594 · URI Credential Leakage Bypass over CVE-2025-27221
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.
CVSS 2.1 · Niedrig · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
uri
- Softwareversionen
- < 0.12.5: Betroffen
- >= 0.13.0, < 0.13.3: Betroffen
- >= 1.0.0, < 1.0.4: Betroffen
Keine Korrektur veröffentlicht
ruby3.1 Debian:12
- Softwareversionen
- 3.1.2-7
- 3.1.2-7+deb12u1
- 3.1.2-7+hurd.1
- 3.1.2-8
- 3.1.2-8.1~exp1
- 3.1.2-8.3
- 3.1.2-8.4
- 3.1.2-8.5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Debian:13
- Softwareversionen
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Debian:14
- Softwareversionen
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rubygems Debian:12
- Softwareversionen
- 3.3.15-2
- 3.3.15-2+deb12u1
- 3.4.20-1
- 3.4.20-1~0
- 3.6.3-1
- 3.6.6-1
- 3.6.7-1
- 3.6.7-2
- 3.6.7-3~exp1
- 4.0.15-1
- 4.0.15-2
- 4.0.18-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rubygems Debian:13
- Softwareversionen
- 3.6.7-2
- 3.6.7-3~exp1
- 4.0.15-1
- 4.0.15-2
- 4.0.18-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rubygems Debian:14
- Softwareversionen
- 3.6.7-2
- 3.6.7-3~exp1
- 4.0.15-1
- 4.0.15-2
- 4.0.18-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby2.3 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- 2.3.1-2~16.04.7
- 2.3.1-2~16.04.9
- 2.3.1-2~16.04.10
- 2.3.1-2~16.04.11
- 2.3.1-2~16.04.12
- 2.3.1-2~ubuntu16.04.13
- 2.3.1-2~ubuntu16.04.14
- 2.3.1-2~ubuntu16.04.15
- 2.3.1-2~ubuntu16.04.16
- 2.3.1-2~ubuntu16.04.16+esm1
- 2.3.1-2~ubuntu16.04.16+esm2
- 2.3.1-2~ubuntu16.04.16+esm3
- 2.3.1-2~ubuntu16.04.16+esm4
- 2.3.1-2~ubuntu16.04.16+esm5
- 2.3.1-2~ubuntu16.04.16+esm6
- 2.3.1-2~ubuntu16.04.16+esm7
- 2.3.1-2~ubuntu16.04.16+esm8
- 2.3.1-2~ubuntu16.04.16+esm9
- 2.3.1-2~ubuntu16.04.16+esm10
- 2.3.1-2~ubuntu16.04.16+esm11
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.1-2~ubuntu16.04.16+esm12
Auf 2.3.1-2~ubuntu16.04.16+esm12 aktualisieren
ruby2.5 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.5.0~preview1-1ubuntu2
- 2.5.0-4ubuntu1
- 2.5.0-4ubuntu4
- 2.5.0-5ubuntu1
- 2.5.0-6ubuntu1
- 2.5.1-1ubuntu1
- 2.5.1-1ubuntu1.1
- 2.5.1-1ubuntu1.2
- 2.5.1-1ubuntu1.4
- 2.5.1-1ubuntu1.5
- 2.5.1-1ubuntu1.6
- 2.5.1-1ubuntu1.7
- 2.5.1-1ubuntu1.8
- 2.5.1-1ubuntu1.9
- 2.5.1-1ubuntu1.10
- 2.5.1-1ubuntu1.11
- 2.5.1-1ubuntu1.12
- 2.5.1-1ubuntu1.13
- 2.5.1-1ubuntu1.14
- 2.5.1-1ubuntu1.15
- 2.5.1-1ubuntu1.16
- 2.5.1-1ubuntu1.16+esm1
- 2.5.1-1ubuntu1.16+esm3
- 2.5.1-1ubuntu1.16+esm4
- 2.5.1-1ubuntu1.16+esm5
- 2.5.1-1ubuntu1.16+esm6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.5.1-1ubuntu1.16+esm7
Auf 2.5.1-1ubuntu1.16+esm7 aktualisieren
ruby2.7 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.7.0-2
- 2.7.0-3
- 2.7.0-4
- 2.7.0-4ubuntu1
- 2.7.0-5ubuntu1
- 2.7.0-5ubuntu1.1
- 2.7.0-5ubuntu1.2
- 2.7.0-5ubuntu1.3
- 2.7.0-5ubuntu1.4
- 2.7.0-5ubuntu1.5
- 2.7.0-5ubuntu1.6
- 2.7.0-5ubuntu1.7
- 2.7.0-5ubuntu1.8
- 2.7.0-5ubuntu1.9
- 2.7.0-5ubuntu1.10
- 2.7.0-5ubuntu1.11
- 2.7.0-5ubuntu1.12
- 2.7.0-5ubuntu1.13
- 2.7.0-5ubuntu1.14
- 2.7.0-5ubuntu1.15
- 2.7.0-5ubuntu1.16
- 2.7.0-5ubuntu1.17
- 2.7.0-5ubuntu1.18
- 2.7.0-5ubuntu1.18+esm1
- 2.7.0-5ubuntu1.18+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.0-5ubuntu1.18+esm4
Auf 2.7.0-5ubuntu1.18+esm4 aktualisieren
ruby3.0 Ubuntu:22.04:LTS
- Softwareversionen
- 3.0.2-5ubuntu1
- 3.0.2-7
- 3.0.2-7ubuntu2
- 3.0.2-7ubuntu2.1
- 3.0.2-7ubuntu2.2
- 3.0.2-7ubuntu2.3
- 3.0.2-7ubuntu2.4
- 3.0.2-7ubuntu2.5
- 3.0.2-7ubuntu2.6
- 3.0.2-7ubuntu2.7
- 3.0.2-7ubuntu2.8
- 3.0.2-7ubuntu2.10
- 3.0.2-7ubuntu2.11
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.2-7ubuntu2.12
Auf 3.0.2-7ubuntu2.12 aktualisieren
ruby3.2 Ubuntu:24.04:LTS
- Softwareversionen
- 3.2.3-1
- 3.2.3-1build2
- 3.2.3-1build3
- 3.2.3-1ubuntu0.24.04.1
- 3.2.3-1ubuntu0.24.04.3
- 3.2.3-1ubuntu0.24.04.5
- 3.2.3-1ubuntu0.24.04.6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.2.3-1ubuntu0.24.04.7
Auf 3.2.3-1ubuntu0.24.04.7 aktualisieren
ruby3.3 Ubuntu:25.10
- Softwareversionen
- 3.3.7-1ubuntu2
- 3.3.8-2ubuntu1
- 3.3.8-2ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.3.8-2ubuntu2.1
Auf 3.3.8-2ubuntu2.1 aktualisieren
ruby3.3 Ubuntu:26.10
- Softwareversionen
- 3.3.8-2ubuntu3
- 3.3.8-2.2ubuntu4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Ubuntu:26.04:LTS
- Softwareversionen
- 3.3.8-2ubuntu2
- 3.3.8-2ubuntu3
- 3.3.8-2ubuntu3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht