p PatchFirst

CVE-2025-61907

CVE-2025-61907 · Icinga 2 API users could access restricted values in filter expressions

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Icinga 2 is an open source monitoring system. In Icinga 2 versions 2.4 through 2.15.0, filter expressions provided to the various /v1/objects endpoints could access variables or objects that would otherwise be inaccessible for the user. This allows authenticated API users to learn information that should be hidden from them, including global variables not permitted by the variables permission and objects not permitted by the corresponding objects/query permissions. The vulnerability is fixed in versions 2.15.1, 2.14.7, and 2.13.13.

CVSS 7.1 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • icinga2

    Softwareversionen
    • >= 2.15.0, < 2.15.1: Betroffen
    • >= 2.14.0, < 2.14.7: Betroffen
    • >= 2.4.0, < 2.13.13: Betroffen

    Keine Korrektur veröffentlicht

  • icinga2 Debian:12

    Softwareversionen
    • 2.13.6-2
    • 2.13.6-2+deb12u1
    • 2.13.6-2+deb12u2
    • 2.13.7-1
    • 2.13.7-1~exp1
    • 2.13.8-1
    • 2.14.0-1~exp1
    • 2.14.1-1
    • 2.14.2-1
    • 2.14.2-1+loong64
    • 2.14.3-1
    • 2.14.4-1
    • 2.14.5-1
    • 2.14.6-1
    • 2.15.0-1
    • 2.15.0-1~exp1
    • 2.15.1-1
    • 2.15.2-1
    • 2.15.2-2
    • 2.16.0-1
    • 2.16.0-2
    • 2.16.0-3~exp1
    • 2.16.0-3~exp2
    • 2.16.0-3~exp3
    • 2.16.0-3~exp4
    • 2.16.1-1
    • 2.16.1-1~exp1
    • 2.16.2-1
    • 2.16.2-2
    • 2.16.3-1
    • 2.16.4-1
    • 2.16.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icinga2 Debian:13

    Softwareversionen
    • 2.14.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.14.6-1+deb13u1

    Auf 2.14.6-1+deb13u1 aktualisieren

  • icinga2 Debian:14

    Softwareversionen
    • 2.14.6-1
    • 2.15.0-1
    • 2.15.0-1~exp1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.15.1-1

    Auf 2.15.1-1 aktualisieren

  • icinga2 Ubuntu:16.04:LTS

    Softwareversionen
    • 2.3.8-1build1
    • 2.3.11-1
    • 2.4.0-1
    • 2.4.1-1
    • 2.4.1-2
    • 2.4.1-2ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icinga2 Ubuntu:18.04:LTS

    Softwareversionen
    • 2.7.0-1
    • 2.8.1-0ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icinga2 Ubuntu:20.04:LTS

    Softwareversionen
    • 2.10.5-1build1
    • 2.11.2-1
    • 2.11.2-1ubuntu1
    • 2.11.2-1ubuntu2
    • 2.11.2-1ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icinga2 Ubuntu:22.04:LTS

    Softwareversionen
    • 2.12.3-1
    • 2.13.1-1
    • 2.13.2-1
    • 2.13.2-1build1
    • 2.13.2-1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icinga2 Ubuntu:24.04:LTS

    Softwareversionen
    • 2.13.8-1
    • 2.14.1-1
    • 2.14.2-1
    • 2.14.2-1build1
    • 2.14.2-1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icinga2 Ubuntu:25.10

    Softwareversionen
    • 2.14.5-1
    • 2.14.6-1
    • 2.15.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icinga2 Ubuntu:26.04:LTS

    Softwareversionen
    • 2.15.0-1
    • 2.15.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →