CVE-2025-6210
CVE-2025-6210 · Hardlink-Based Path Traversal in run-llama/llama_index
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0.12.27, allows for hardlink-based path traversal. This flaw permits attackers to bypass path restrictions and access sensitive system files, such as /etc/passwd, by exploiting hardlinks. The vulnerability arises from inadequate handling of hardlinks in the load_data() method, where the security checks fail to differentiate between real files and hardlinks. This issue is resolved in version 0.5.2.
CVSS 6.2 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
run-llama/llama_index
- Softwareversionen
- ≥ unspecified, < 0.5.2: Betroffen (custom)
Auf 0.5.2 aktualisieren
llama-index-readers-obsidian PyPI
- Softwareversionen
- 0.0.1
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.2.0
- 0.3.0
- 0.4.0
- 0.5.0
- 0.5.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.5.2
Auf 0.5.2 aktualisieren
llama-index PyPI
- Softwareversionen
- 0.4.10
- 0.4.11
- 0.4.12
- 0.4.13
- 0.4.14
- 0.4.15
- 0.4.16
- 0.4.17
- 0.4.18
- 0.4.19
- 0.4.20
- 0.4.21
- 0.4.22
- 0.4.22.post1
- 0.4.23
- 0.4.24
- 0.4.25
- 0.4.26
- 0.4.27
- 0.4.28
- 0.4.29
- 0.4.30
- 0.4.31
- 0.4.32
- 0.4.33
- 0.4.34
- 0.4.35
- 0.4.35.post1
- 0.4.36
- 0.4.37
- 0.4.38
- 0.4.39
- 0.4.4
- 0.4.4.post1
- 0.4.4.post2
- 0.4.40
- 0.4.5
- 0.4.6
- 0.4.7
- 0.4.8
- 0.4.9
- 0.5.0
- 0.5.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.5.2
Auf 0.5.2 aktualisieren