CVE-2025-62427
CVE-2025-62427 · Server-Side Request Forgery (SSRF) in Angular SSR
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The Angular SSR is a server-rise rendering tool for Angular applications. The vulnerability is a Server-Side Request Forgery (SSRF) flaw within the URL resolution mechanism of Angular's Server-Side Rendering package (@angular/ssr) before 19.2.18, 20.3.6, and 21.0.0-next.8. The function createRequestUrl uses the native URL constructor. When an incoming request path (e.g., originalUrl or url) begins with a double forward slash (//) or backslash (\\), the URL constructor treats it as a schema-relative URL. This behavior overrides the security-intended base URL (protocol, host, and port) supplied as the second argument, instead resolving the URL against the scheme of the base URL but adopting the attacker-controlled hostname. This allows an attacker to specify an external domain in the URL path, tricking the Angular SSR environment into setting the page's virtual location (accessible via DOCUMENT or PlatformLocation tokens) to this attacker-controlled domain. Any subsequent relative HTTP requests made during the SSR process (e.g., using HttpClient.get('assets/data.json')) will be incorrectly resolved against the attacker's domain, forcing the server to communicate with an arbitrary external endpoint. This vulnerability is fixed in 19.2.18, 20.3.6, and 21.0.0-next.8.
CVSS 8.7 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
angular-cli
- Softwareversionen
- >=19.0.0-next.0, < 19.2.18: Betroffen
- >=20.0.0-next.0, < 20.3.6: Betroffen
- >=21.0.0-next.0, < 21.0.0-next.8: Betroffen
Keine Korrektur veröffentlicht
@angular/ssr npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 19.0.0-next.0, < 19.2.18
Auf 19.2.18 aktualisieren
@angular/ssr npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 20.0.0-next.0, < 20.3.6
Auf 20.3.6 aktualisieren
@angular/ssr npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 21.0.0-next.0, < 21.0.0-next.8
Auf 21.0.0-next.8 aktualisieren