p PatchFirst

CVE-2025-62522

CVE-2025-62522 · vite allows server.fs.deny bypass via backslash on Windows

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vite is a frontend tooling framework for JavaScript. In versions from 2.9.18 to before 3.0.0, 3.2.9 to before 4.0.0, 4.5.3 to before 5.0.0, 5.2.6 to before 5.4.21, 6.0.0 to before 6.4.1, 7.0.0 to before 7.0.8, and 7.1.0 to before 7.1.11, files denied by server.fs.deny were sent if the URL ended with \ when the dev server is running on Windows. Only apps explicitly exposing the Vite dev server to the network and running the dev server on Windows were affected. This issue has been patched in versions 5.4.21, 6.4.1, 7.0.8, and 7.1.11.

CVSS 6.0 · Mittel · EPSS 1,1% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • vite

    Softwareversionen
    • >= 7.1.0, < 7.1.11: Betroffen
    • >= 7.0.0, < 7.0.8: Betroffen
    • >= 6.0.0, < 6.4.1: Betroffen
    • >= 5.2.6, < 5.4.21: Betroffen
    • >= 4.5.3, < 5.0.0: Betroffen
    • >= 3.2.9, < 4.0.0: Betroffen
    • >= 2.9.18, < 3.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.1.0, < 7.1.11

    Auf 7.1.11 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0, < 7.0.8

    Auf 7.0.8 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.0.0, < 6.4.1

    Auf 6.4.1 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.9.18, < 5.4.21

    Auf 5.4.21 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.2.9, < 5.4.21

    Auf 5.4.21 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.5.3, < 5.4.21

    Auf 5.4.21 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.2.6, < 5.4.21

    Auf 5.4.21 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →