p PatchFirst

CVE-2025-65012

CVE-2025-65012 · Kirby CMS has cross-site scripting (XSS) in the changes dialog

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Kirby is an open-source content management system. From versions 5.0.0 to 5.1.3, attackers could change the title of any page or the name of any user to a malicious string. Then they could modify any content field of the same model without saving, making the model a candidate for display in the "Changes" dialog. If another authenticated user subsequently opened the dialog in their Panel, the malicious code would be executed. This vulnerability affects all Kirby 5 sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update page titles or usernames. The attack requires user interaction by another Panel user and cannot be automated. This issue has been patched in version 5.1.4.

CVSS 5.1 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • kirby

    Softwareversionen
    • >= 5.0.0, < 5.1.4: Betroffen

    Keine Korrektur veröffentlicht

  • getkirby/cms Packagist

    Softwareversionen
    • 5.0.0
    • 5.0.1
    • 5.0.2
    • 5.0.3
    • 5.0.4
    • 5.1.0
    • 5.1.0-rc.1
    • 5.1.1
    • 5.1.2
    • 5.1.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 5.0.0, < 5.1.4

    Auf 5.1.4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →