CVE-2025-65018
CVE-2025-65018 · LIBPNG is vulnerable to a heap buffer overflow in `png_combine_row` triggered via `png_image_finish_read`
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, there is a heap buffer overflow vulnerability in the libpng simplified API function png_image_finish_read when processing 16-bit interlaced PNGs with 8-bit output format. Attacker-crafted interlaced PNG files cause heap writes beyond allocated buffer bounds. This issue has been patched in version 1.6.51.
CVSS 7.1 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libpng
- Softwareversionen
- >= 1.6.0, < 1.6.51: Betroffen
Keine Korrektur veröffentlicht
libpng1.6 Debian:12
- Softwareversionen
- 1.6.39-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.39-2+deb12u1
Auf 1.6.39-2+deb12u1 aktualisieren
libpng1.6 Debian:13
- Softwareversionen
- 1.6.48-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.48-1+deb13u1
Auf 1.6.48-1+deb13u1 aktualisieren
libpng1.6 Debian:14
- Softwareversionen
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.51-1
Auf 1.6.51-1 aktualisieren
libpng1.6 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm2
Auf 1.6.20-2ubuntu0.1~esm2 aktualisieren
libpng1.6 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm1
Auf 1.6.34-1ubuntu0.18.04.2+esm1 aktualisieren
libpng1.6 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.6.37-1
- 1.6.37-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm1
Auf 1.6.37-2ubuntu0.1~esm1 aktualisieren
libpng1.6 Ubuntu:22.04:LTS
- Softwareversionen
- 1.6.37-3build4
- 1.6.37-3build5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.37-3ubuntu0.1
Auf 1.6.37-3ubuntu0.1 aktualisieren
libpng1.6 Ubuntu:24.04:LTS
- Softwareversionen
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.43-5ubuntu0.1
Auf 1.6.43-5ubuntu0.1 aktualisieren
libpng1.6 Ubuntu:25.10
- Softwareversionen
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.50-1ubuntu0.1
Auf 1.6.50-1ubuntu0.1 aktualisieren
Originalquellen
- https://github.com/pnggroup/libpng/security/advisories/GHSA-7wv6-48j4-hj3g
- https://github.com/pnggroup/libpng/issues/755
- https://github.com/pnggroup/libpng/pull/757
- https://github.com/pnggroup/libpng/commit/16b5e3823918840aae65c0a6da57c78a5a496a4d
- https://github.com/pnggroup/libpng/commit/218612ddd6b17944e21eda56caf8b4bf7779d1ea
- https://nvd.nist.gov/vuln/detail/CVE-2025-65018