CVE-2025-65955
CVE-2025-65955 · ImageMagick has a use-after-free/double-free risk in Options::fontFamily when clearing family
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-9 and 6.9.13-34, there is a vulnerability in ImageMagick’s Magick++ layer that manifests when Options::fontFamily is invoked with an empty string. Clearing a font family calls RelinquishMagickMemory on _drawInfo->font, freeing the font string but leaving _drawInfo->font pointing to freed memory while _drawInfo->family is set to that (now-invalid) pointer. Any later cleanup or reuse of _drawInfo->font re-frees or dereferences dangling memory. DestroyDrawInfo and other setters (Options::font, Image::font) assume _drawInfo->font remains valid, so destruction or subsequent updates trigger crashes or heap corruption. This vulnerability is fixed in 7.1.2-9 and 6.9.13-34.
CVSS 4.9 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
imagemagick
- Softwareversionen
- >= 7.0.1-0, < 7.1.2-9: Betroffen
- < 6.9.13-34: Betroffen
Keine Korrektur veröffentlicht
imagemagick Debian:12
- Softwareversionen
- 8:6.9.11.60+dfsg-1.6
- 8:6.9.11.60+dfsg-1.6+deb12u1
- 8:6.9.11.60+dfsg-1.6+deb12u2
- 8:6.9.11.60+dfsg-1.6+deb12u3
- 8:6.9.11.60+dfsg-1.6+deb12u4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:6.9.11.60+dfsg-1.6+deb12u5
Auf 8:6.9.11.60+dfsg-1.6+deb12u5 aktualisieren
imagemagick Debian:13
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1+deb13u1
- 8:7.1.1.43+dfsg1-1+deb13u2
- 8:7.1.1.43+dfsg1-1+deb13u3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:7.1.1.43+dfsg1-1+deb13u4
Auf 8:7.1.1.43+dfsg1-1+deb13u4 aktualisieren
imagemagick Debian:14
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.46+dfsg1-1
- 8:7.1.1.47+dfsg1-1
- 8:7.1.1.47+dfsg1-2
- 8:7.1.2.1+dfsg1-1
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.7+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:7.1.2.12+dfsg1-1
Auf 8:7.1.2.12+dfsg1-1 aktualisieren
Originalquellen
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-q3hc-j9x5-mp9m
- https://github.com/ImageMagick/ImageMagick/commit/6409f34d637a34a1c643632aa849371ec8b3b5a8
- https://github.com/ImageMagick/ImageMagick/commit/6f81eb15f822ad86e8255be75efad6f9762c32f8
- https://nvd.nist.gov/vuln/detail/CVE-2025-65955