p PatchFirst

CVE-2025-66388

CVE-2025-66388 · Apache Airflow: Secrets in rendered templates not redacted properly and exposed in the UI

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4, which fixes this issue.

CVSS 4.3 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • apache airflow

    Softwareversionen
    • ≥ 3.1.0, < 3.1.4: Betroffen (semver)

    Auf 3.1.4 aktualisieren

  • apache-airflow PyPI

    Softwareversionen
    • 3.1.0
    • 3.1.1
    • 3.1.1rc1
    • 3.1.1rc2
    • 3.1.2
    • 3.1.2rc1
    • 3.1.2rc2
    • 3.1.3
    • 3.1.3rc1
    • 3.1.4
    • 3.1.4rc1
    • 3.1.4rc2
    • 3.1.5rc1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.5

    Auf 3.1.5 aktualisieren

  • apache-airflow PyPI

    Softwareversionen
    • 3.1.0
    • 3.1.1
    • 3.1.1rc1
    • 3.1.1rc2
    • 3.1.2
    • 3.1.2rc1
    • 3.1.2rc2
    • 3.1.3
    • 3.1.3rc1
    • 3.1.4rc1
    • 3.1.4rc2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.4

    Auf 3.1.4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →