p PatchFirst

CVE-2025-66570

CVE-2025-66570 · cpp-httplib Untrusted HTTP Header Handling: Internal Header Shadowing (REMOTE*/LOCAL*)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. Prior to 0.27.0, a vulnerability allows attacker-controlled HTTP headers to influence server-visible metadata, logging, and authorization decisions. An attacker can inject headers named REMOTE_ADDR, REMOTE_PORT, LOCAL_ADDR, LOCAL_PORT that are parsed into the request header multimap via read_headers() in httplib.h (headers.emplace), then the server later appends its own internal metadata using the same header names in Server::process_request without erasing duplicates. Because Request::get_header_value returns the first entry for a header key (id == 0) and the client-supplied headers are parsed before server-inserted headers, downstream code that uses these header names may inadvertently use attacker-controlled values. Affected files/locations: cpp-httplib/httplib.h (read_headers, Server::process_request, Request::get_header_value, get_header_value_u64) and cpp-httplib/docker/main.cc (get_client_ip, nginx_access_logger, nginx_error_logger). Attack surface: attacker-controlled HTTP headers in incoming requests flow into the Request.headers multimap and into logging code that reads forwarded headers, enabling IP spoofing, log poisoning, and authorization bypass via header shadowing. This vulnerability is fixed in 0.27.0.

CVSS 10.0 · Kritisch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • cpp-httplib

    Softwareversionen
    • < 0.27.0: Betroffen

    Keine Korrektur veröffentlicht

  • cpp-httplib Debian:12

    Softwareversionen
    • 0.11.4+ds-1
    • 0.11.4+ds-1+deb12u1
    • 0.11.4+ds-2
    • 0.11.4+ds-3
    • 0.13.1+ds-1
    • 0.14.0+ds-1
    • 0.14.1+ds-1
    • 0.14.1+ds-2
    • 0.14.2+ds-1
    • 0.14.3+ds-1
    • 0.14.3+ds-1.1
    • 0.14.3+ds-1.1~exp1
    • 0.15.3+ds-1
    • 0.15.3+ds-2
    • 0.15.3+ds-3
    • 0.16.0+ds-1
    • 0.16.3+ds-1
    • 0.16.3+ds-2
    • 0.18.0+ds-1
    • 0.18.7-1
    • 0.20.1+ds-3
    • 0.25.0+ds-1
    • 0.26.0+ds-2
    • 0.41.0+ds-1
    • 0.41.0+ds-2
    • 0.41.0+ds-3
    • 0.41.0+ds-3~bpo13+1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cpp-httplib Debian:13

    Softwareversionen
    • 0.18.7-1
    • 0.18.7-1+deb13u1
    • 0.20.1+ds-3
    • 0.25.0+ds-1
    • 0.26.0+ds-2
    • 0.41.0+ds-1
    • 0.41.0+ds-2
    • 0.41.0+ds-3
    • 0.41.0+ds-3~bpo13+1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cpp-httplib Debian:14

    Softwareversionen
    • 0.18.7-1
    • 0.20.1+ds-3
    • 0.25.0+ds-1
    • 0.26.0+ds-2
    • 0.41.0+ds-1
    • 0.41.0+ds-2
    • 0.41.0+ds-3~bpo13+1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.41.0+ds-3

    Auf 0.41.0+ds-3 aktualisieren

  • cpp-httplib Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 0.9.9+ds-1
    • 0.9.10+ds-1
    • 0.10.1+ds-1
    • 0.10.2+ds-1
    • 0.10.3+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.10.3+ds-1ubuntu0.1~esm1

    Auf 0.10.3+ds-1ubuntu0.1~esm1 aktualisieren

  • cpp-httplib Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 0.13.1+ds-1ubuntu1
    • 0.14.3+ds-1
    • 0.14.3+ds-1.1
    • 0.14.3+ds-1.1build1
    • 0.14.3+ds-1.1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.14.3+ds-1.1ubuntu0.1~esm1

    Auf 0.14.3+ds-1.1ubuntu0.1~esm1 aktualisieren

  • cpp-httplib Ubuntu:25.10

    Softwareversionen
    • 0.18.7-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.18.7-1ubuntu0.25.10.1

    Auf 0.18.7-1ubuntu0.25.10.1 aktualisieren

  • cpp-httplib Ubuntu:26.10

    Softwareversionen
    • 0.26.0+ds-2ubuntu3
    • 0.26.0+ds-2ubuntu4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cpp-httplib Ubuntu:Pro:26.04:LTS

    Softwareversionen
    • 0.18.7-1
    • 0.26.0+ds-2ubuntu2
    • 0.26.0+ds-2ubuntu3
    • 0.26.0+ds-2ubuntu3+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →