CVE-2025-67746
CVE-2025-67746 · Composer vulnerable to ANSI sequence injection
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
CVSS 1.3 · Niedrig · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
composer
- Softwareversionen
- >= 2.0, < 2.2.26: Betroffen
- >= 2.3, < 2.9.3: Betroffen
Keine Korrektur veröffentlicht
composer Debian:12
- Softwareversionen
- 2.5.5-1
- 2.5.5-1+deb12u1
- 2.5.5-1+deb12u2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.5.5-1+deb12u3
Auf 2.5.5-1+deb12u3 aktualisieren
composer Debian:13
- Softwareversionen
- 2.8.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.8.8-1+deb13u1
Auf 2.8.8-1+deb13u1 aktualisieren
composer Debian:14
- Softwareversionen
- 2.8.10-1
- 2.8.11-1
- 2.8.11-2
- 2.8.12-1
- 2.8.8-1
- 2.8.9-1
- 2.9.0~rc1-1
- 2.9.1-1
- 2.9.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.9.3-1
Auf 2.9.3-1 aktualisieren
composer/composer Packagist
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.13
- 2.0.14
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1.0
- 2.1.0-RC1
- 2.1.1
- 2.1.10
- 2.1.11
- 2.1.12
- 2.1.14
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.1.7
- 2.1.8
- 2.1.9
- 2.2.0
- 2.2.0-RC1
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.14
- 2.2.15
- 2.2.16
- 2.2.17
- 2.2.18
- 2.2.19
- 2.2.2
- 2.2.20
- 2.2.21
- 2.2.22
- 2.2.23
- 2.2.24
- 2.2.25
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.2.26
Auf 2.2.26 aktualisieren
composer/composer Packagist
- Softwareversionen
- 2.3.0
- 2.3.1
- 2.3.10
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 2.3.8
- 2.3.9
- 2.4.0
- 2.4.0-RC1
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.7.0
- 2.7.1
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.8.0
- 2.8.1
- 2.8.10
- 2.8.11
- 2.8.12
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.8.9
- 2.9.0
- 2.9.0-RC1
- 2.9.1
- 2.9.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.9.3
Auf 2.9.3 aktualisieren
composer Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.0.0~alpha10+20150602-1
- 1.0.0~alpha10+20150602-2
- 1.0.0~alpha11-1
- 1.0.0~alpha11-1ubuntu1
- 1.0.0~alpha11-2
- 1.0.0~alpha11-3
- 1.0.0~beta1-1ubuntu1
- 1.0.0~beta2-1
- 1.0.0~beta2-1ubuntu0.1~esm1
- 1.0.0~beta2-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
composer Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.5.1-1
- 1.5.2-1
- 1.6.2-1
- 1.6.3-1
- 1.6.3-1ubuntu0.1~esm1
- 1.6.3-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
composer Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.9.0-2
- 1.9.1-1
- 1.9.2-1
- 1.9.3-1
- 1.10.0-1
- 1.10.1-1
- 1.10.1-1ubuntu0.1~esm1
- 1.10.1-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
composer Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2.0.9-2ubuntu2
- 2.0.9-2ubuntu3
- 2.0.13-1ubuntu1
- 2.1.12-1ubuntu1
- 2.2.6-2ubuntu4
- 2.2.6-2ubuntu4+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
composer Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 2.5.8-1
- 2.6.5-1
- 2.6.6-1
- 2.7.1-2
- 2.7.1-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
composer Ubuntu:25.10
- Softwareversionen
- 2.8.6-1
- 2.8.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
composer Ubuntu:26.04:LTS
- Softwareversionen
- 2.8.8-1
- 2.9.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/composer/composer/security/advisories/GHSA-59pp-r3rg-353g
- https://github.com/composer/composer/commit/1d40a95c9d39a6b7f80d404ab30336c586da9917
- https://github.com/composer/composer/commit/5db1876a76fdef76d3c4f8a27995c434c7a43e71
- https://github.com/composer/composer/releases/tag/2.2.26
- https://github.com/composer/composer/releases/tag/2.9.3
- https://nvd.nist.gov/vuln/detail/CVE-2025-67746