p PatchFirst

CVE-2025-68157

CVE-2025-68157 · webpack buildHttp HttpUriPlugin allowedUris bypass via HTTP redirects

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Webpack is a module bundler. From version 5.49.0 to before 5.104.0, when experiments.buildHttp is enabled, webpack’s HTTP(S) resolver (HttpUriPlugin) enforces allowedUris only for the initial URL, but does not re-validate allowedUris after following HTTP 30x redirects. As a result, an import that appears restricted to a trusted allow-list can be redirected to HTTP(S) URLs outside the allow-list. This is a policy/allow-list bypass that enables build-time SSRF behavior (requests from the build machine to internal-only endpoints, depending on network access) and untrusted content inclusion in build outputs (redirected content is treated as module source and bundled). This issue has been patched in version 5.104.0.

CVSS 3.7 · Niedrig · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • webpack

    Softwareversionen
    • >= 5.49.0, < 5.104.0: Betroffen

    Keine Korrektur veröffentlicht

  • node-webpack Debian:12

    Softwareversionen
    • 5.105.4+dfsg1+~cs15.13.23-1
    • 5.105.4+dfsg1+~cs15.13.23-2
    • 5.105.4+dfsg1+~cs15.13.23-3
    • 5.106.2+dfsg1+~cs15.15.23-1
    • 5.106.2+dfsg1+~cs15.15.23-2
    • 5.106.2+dfsg1+~cs15.15.23-3
    • 5.107.2+dfsg1+~cs15.16.25-1
    • 5.107.2+dfsg1+~cs15.16.25-1.1
    • 5.107.2+dfsg1+~cs15.16.25-2
    • 5.108.0+dfsg1+~cs14.7.20-1
    • 5.108.0+dfsg1+~cs14.7.20-2
    • 5.108.0+dfsg1+~cs14.7.20-3
    • 5.75.0+dfsg+~cs17.16.14-1
    • 5.75.0+dfsg+~cs17.16.14-1+deb12u1
    • 5.76.1+dfsg1+~cs17.16.16-1
    • 5.76.1+dfsg2+~cs10.8.15-2
    • 5.76.1+dfsg2+~cs10.8.15-3
    • 5.94.0+dfsg1+~cs11.18.26-1
    • 5.94.0+dfsg1+~cs11.18.26-2
    • 5.95.0+dfsg1+~cs11.18.26-1
    • 5.96.1+dfsg1+~cs11.18.26-1
    • 5.97.1+dfsg1+~cs11.18.27-1
    • 5.97.1+dfsg1+~cs11.18.27-2
    • 5.97.1+dfsg1+~cs11.18.27-3
    • 5.97.1+dfsg1+~cs11.18.27-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Debian:13

    Softwareversionen
    • 5.105.4+dfsg1+~cs15.13.23-1
    • 5.105.4+dfsg1+~cs15.13.23-2
    • 5.105.4+dfsg1+~cs15.13.23-3
    • 5.106.2+dfsg1+~cs15.15.23-1
    • 5.106.2+dfsg1+~cs15.15.23-2
    • 5.106.2+dfsg1+~cs15.15.23-3
    • 5.107.2+dfsg1+~cs15.16.25-1
    • 5.107.2+dfsg1+~cs15.16.25-1.1
    • 5.107.2+dfsg1+~cs15.16.25-2
    • 5.108.0+dfsg1+~cs14.7.20-1
    • 5.108.0+dfsg1+~cs14.7.20-2
    • 5.108.0+dfsg1+~cs14.7.20-3
    • 5.97.1+dfsg1+~cs11.18.27-3
    • 5.97.1+dfsg1+~cs11.18.27-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Debian:14

    Softwareversionen
    • 5.105.4+dfsg1+~cs15.13.23-1
    • 5.97.1+dfsg1+~cs11.18.27-3
    • 5.97.1+dfsg1+~cs11.18.27-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.105.4+dfsg1+~cs15.13.23-2

    Auf 5.105.4+dfsg1+~cs15.13.23-2 aktualisieren

  • webpack npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.49.0, < 5.104.0

    Auf 5.104.0 aktualisieren

  • node-webpack Ubuntu:18.04:LTS

    Softwareversionen
    • 3.5.6-1build3
    • 3.5.6-1build4
    • 3.5.6-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:20.04:LTS

    Softwareversionen
    • 4.7.0-3
    • 4.30.0-7
    • 4.30.0-9
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:22.04:LTS

    Softwareversionen
    • 4.43.0-6build4
    • 4.43.0-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:24.04:LTS

    Softwareversionen
    • 5.76.1+dfsg1+~cs17.16.16-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:25.10

    Softwareversionen
    • 5.97.1+dfsg1+~cs11.18.27-2
    • 5.97.1+dfsg1+~cs11.18.27-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:26.10

    Softwareversionen
    • 5.105.4+dfsg1+~cs15.13.23-2
    • 5.108.0+dfsg1+~cs14.7.20-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:26.04:LTS

    Softwareversionen
    • 5.97.1+dfsg1+~cs11.18.27-3
    • 5.97.1+dfsg1+~cs11.18.27-4
    • 5.105.4+dfsg1+~cs15.13.23-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →