CVE-2025-69219
CVE-2025-69219 · Apache Airflow Providers Http: Unsafe Pickle Deserialization in apache-airflow-providers-http leading to RCE via HttpOperator
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low. You should upgrade to version 6.0.0 of the provider to avoid even that risk.
CVSS 8.8 · Hoch · EPSS 0,7% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
apache airflow providers http
- Softwareversionen
- ≥ 5.1.0, < 6.0.0: Betroffen (semver)
Auf 6.0.0 aktualisieren
apache-airflow-providers-http PyPI
- Softwareversionen
- 1.0.0
- 1.0.0b1
- 1.0.0b2
- 1.0.0rc1
- 1.1.0
- 1.1.0rc1
- 1.1.1
- 1.1.1rc1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.1
- 2.0.1rc1
- 2.0.2
- 2.0.2rc1
- 2.0.3
- 2.0.3rc1
- 2.0.3rc2
- 2.1.0
- 2.1.0rc1
- 2.1.1
- 2.1.1rc1
- 2.1.2
- 2.1.2rc1
- 3.0.0
- 3.0.0rc1
- 3.0.0rc2
- 4.0.0
- 4.0.0rc1
- 4.1.0
- 4.1.0rc1
- 4.1.1
- 4.1.1rc1
- 4.10.0
- 4.10.0rc1
- 4.10.1
- 4.10.1rc1
- 4.11.0
- 4.11.0rc1
- 4.11.1
- 4.11.1rc1
- 4.12.0
- 4.12.0rc1
- 4.13.0
- 4.13.0rc1
- 4.13.1
- 4.13.1rc1
- 4.13.2
- 4.13.2rc1
- 4.13.3
- 4.13.3rc1
- 4.2.0
- 4.2.0rc1
- 4.3.0
- 4.3.0rc1
- 4.4.0
- 4.4.0rc1
- 4.4.0rc2
- 4.4.1
- 4.4.1rc1
- 4.4.2
- 4.4.2rc1
- 4.5.0
- 4.5.0rc1
- 4.5.1
- 4.5.1rc1
- 4.5.2
- 4.5.2rc1
- 4.6.0
- 4.6.0rc1
- 4.7.0
- 4.7.0rc1
- 4.7.0rc2
- 4.8.0
- 4.8.0rc1
- 4.9.0
- 4.9.0rc1
- 4.9.0rc2
- 4.9.1
- 4.9.1rc1
- 5.0.0
- 5.0.0rc1
- 5.0.0rc2
- 5.1.0
- 5.2.0
- 5.2.0rc1
- 5.2.1
- 5.2.1rc1
- 5.2.2
- 5.2.2rc1
- 5.3.0
- 5.3.0rc1
- 5.3.1
- 5.3.1rc1
- 5.3.2
- 5.3.2rc1
- 5.3.3
- 5.3.3rc1
- 5.3.4
- 5.3.4rc1
- 5.4.0
- 5.4.0rc1
- 5.5.0
- 5.5.0rc1
- 5.6.0
- 5.6.0rc1
- 5.6.1
- 5.6.1rc1
- 5.6.2
- 5.6.2rc1
- 5.6.3
- 5.6.3rc1
- 5.6.4
- 5.6.4rc1
- 6.0.0rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.0
Auf 6.0.0 aktualisieren