CVE-2025-9136
CVE-2025-9136 · libretro RetroArch file_stream.c filestream_vscanf out-of-bounds
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A flaw has been found in libretro RetroArch 1.18.0/1.19.0/1.20.0. This affects the function filestream_vscanf of the file libretro-common/streams/file_stream.c. This manipulation causes out-of-bounds read. The attack needs to be launched locally. Upgrading to version 1.21.0 mitigates this issue. It is recommended to upgrade the affected component.
CVSS 4.8 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
retroarch
- Softwareversionen
- 1.18.0: Betroffen
- 1.19.0: Betroffen
- 1.20.0: Betroffen
- 1.21.0: Nicht betroffen
Auf 1.21.0 aktualisieren
retroarch Debian:12
- Softwareversionen
- 1.14.0+dfsg-1
- 1.15.0+dfsg-1
- 1.16.0.3+dfsg-1
- 1.18.0+dfsg-1
- 1.19.1+dfsg-1
- 1.20.0+dfsg-1
- 1.20.0+dfsg-2
- 1.20.0+dfsg-3
- 1.22.2+dfsg-1
- 1.22.2+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Debian:13
- Softwareversionen
- 1.20.0+dfsg-2
- 1.20.0+dfsg-3
- 1.22.2+dfsg-1
- 1.22.2+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Debian:14
- Softwareversionen
- 1.20.0+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.20.0+dfsg-3
Auf 1.20.0+dfsg-3 aktualisieren
retroarch Ubuntu:18.04:LTS
- Softwareversionen
- 1.4.1+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Ubuntu:20.04:LTS
- Softwareversionen
- 1.7.3+dfsg1-1build1
- 1.7.3+dfsg1-1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.3+dfsg1-1.1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 1.14.0+dfsg-1build1
- 1.15.0+dfsg-1
- 1.16.0.3+dfsg-1
- 1.18.0+dfsg-1
- 1.18.0+dfsg-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Ubuntu:25.10
- Softwareversionen
- 1.20.0+dfsg-2build1
- 1.20.0+dfsg-2build2
- 1.20.0+dfsg-3
- 1.20.0+dfsg-3ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Ubuntu:26.10
- Softwareversionen
- 1.22.2+dfsg-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
retroarch Ubuntu:26.04:LTS
- Softwareversionen
- 1.20.0+dfsg-3
- 1.22.2+dfsg-1
- 1.22.2+dfsg-2
- 1.22.2+dfsg-2build1
- 1.22.2+dfsg-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://vuldb.com/?id.320516
- https://vuldb.com/?ctiid.320516
- https://vuldb.com/?submit.617657
- https://github.com/libretro/RetroArch/pull/17555
- https://github.com/libretro/RetroArch/pull/17555#issuecomment-2651403849
- https://github.com/libretro/RetroArch/pull/17555/commits/6446f045ec7fc6a5cac3e8ec35a2f0a5889c88e8
- https://github.com/libretro/RetroArch/releases/tag/v1.21.0
- https://nvd.nist.gov/vuln/detail/CVE-2025-9136