p PatchFirst

CVE-2026-100351

CVE-2026-100351 · kin-openapi: ValidationHandler security-requirement bypass via encoded-path operation confusion

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

kin-openapi is a Go project for handling OpenAPI files. From 0.144.0 until 0.147.0, openapi3filter.ValidationHandler validates an operation selected from decoded URL.Path while a downstream gorilla/mux router configured with UseEncodedPath can dispatch a different operation selected from URL.RawPath. When a public exact route and a protected parameterized route use the same method and overlap after decoding, an unauthenticated remote request containing an encoded path separator can be validated as public and then dispatched to the protected handler without invoking the configured AuthenticationFunc. The reachable path parameter is constrained to an encoded representation that decodes to the public literal route, and proxies that canonicalize the URI before forwarding prevent this specific mismatch. This issue is fixed in version 0.147.0.

CVSS 7.4 · Hoch · EPSS 0,5%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • kin-openapi

    Softwareversionen
    • >= 0.144.0, < 0.147.0: Betroffen

    Keine Korrektur veröffentlicht

  • golang-github-getkin-kin-openapi Ubuntu:22.04:LTS

    Softwareversionen
    • 0.32.0-2
    • 0.80.0-1
    • 0.85.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • golang-github-getkin-kin-openapi Ubuntu:24.04:LTS

    Softwareversionen
    • 0.117.0-1
    • 0.120.0-1
    • 0.122.0-3
    • 0.123.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • golang-github-getkin-kin-openapi Ubuntu:26.10

    Softwareversionen
    • 0.124.0-1
    • 0.135.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • golang-github-getkin-kin-openapi Ubuntu:26.04:LTS

    Softwareversionen
    • 0.124.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →