CVE-2026-100696
CVE-2026-100696 · Adminer before 6.0.2 Unauthenticated SSRF via Elasticsearch Driver
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Adminer 4.16.0 through 6.0.1 contain a pre-authentication Server-Side Request Forgery (SSRF) vulnerability in the optional Elasticsearch driver (plugins/drivers/elastic.php), fixed in 6.0.2. Because adminer/include/auth.inc.php invokes Driver::connect() before the login result is validated, an unauthenticated attacker who submits crafted auth[server], auth[username], and auth[password] parameters can cause the Adminer server to issue an HTTP GET request (via get_url()/file_get_contents()) to an arbitrary reachable host and port. The driver validates only general server syntax and does not block loopback, private, link-local, or other reserved addresses; if no port is given it appends the default 9200, and Adminer's generic port check rejects ports below 1024. Selected JSON error fields from non-2xx Elasticsearch-style responses, as well as connection failures, are rendered on the login page, providing a port-scanning oracle and enabling internal network reconnaissance and service fingerprinting. Exploitation requires that the optional Elasticsearch driver be explicitly deployed (e.g., via the adminer/elastic.php template or an adminer_object() configuration; it is not loaded in a default build) and that PHP allow_url_fopen be enabled.
CVSS 6.9 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
adminer
- Softwareversionen
- ≥ 0, < 6.0.2: Betroffen (semver)
- 6.0.2: Nicht betroffen (semver)
Auf 6.0.2 aktualisieren
adminer Debian:12
- Softwareversionen
- 4.8.1-1
- 4.8.1-2
- 4.8.1-4
- 5.1.0-1
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- 6.0.2-1
- 6.1.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Debian:13
- Softwareversionen
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- 6.0.2-1
- 6.1.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Debian:14
- Softwareversionen
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.2-1
Auf 6.0.2-1 aktualisieren
adminer Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.2.1-1
- 4.2.1-1ubuntu1
- 4.2.1-1ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.3.1-2
- 4.5.0-1
- 4.6.1-1
- 4.6.2-1
- 4.6.2-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 4.7.2-1
- 4.7.4-1
- 4.7.5-1
- 4.7.6-1
- 4.7.6-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Ubuntu:22.04:LTS
- Softwareversionen
- 4.7.9-2
- 4.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Ubuntu:24.04:LTS
- Softwareversionen
- 4.8.1-1
- 4.8.1-1ubuntu1
- 4.8.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Ubuntu:26.10
- Softwareversionen
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
adminer Ubuntu:26.04:LTS
- Softwareversionen
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht