p PatchFirst

CVE-2026-101895

CVE-2026-101895 · Angular SSR: Denial of Service (DoS) via Infinite Loop on Malformed DOCTYPE

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.31, 21.2.23, and 22.1.6, the @angular/platform-server DOM emulation parser can enter an infinite synchronous loop when Angular server-side rendering processes attacker-controlled HTML containing an incomplete DOCTYPE that ends with whitespace at end of input. In Domino lib/HTMLParser.js, after_doctype_name_state emits doctype and EOF tokens without advancing nextchar or leaving the fixed-lookahead state, so the scanner repeatedly handles the same EOF marker. A remote unauthenticated attacker can use this condition through server-side HTML parsing paths such as innerHTML binding to consume a Node.js SSR worker at full CPU, starve the event loop, and stop concurrent and subsequent requests. This issue is fixed in versions 20.3.31, 21.2.23, and 22.1.6.

CVSS 8.7 · Hoch · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • angular

    Softwareversionen
    • <= 19.2.25: Betroffen
    • >= 20.0.0, < 20.3.31: Betroffen
    • >= 21.0.0, < 21.2.23: Betroffen
    • >= 22.0.0, < 22.1.6: Betroffen

    Keine Korrektur veröffentlicht

  • platform-server

    Softwareversionen
    • <= 19.2.25: Betroffen
    • >= 20.0.0, < 20.3.31: Betroffen
    • >= 21.0.0, < 21.2.23: Betroffen
    • >= 22.0.0, < 22.1.6: Betroffen

    Keine Korrektur veröffentlicht

  • angular.js Debian:12

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Debian:13

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 22.0.0, < 22.1.6

    Auf 22.1.6 aktualisieren

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 21.0.0, < 21.2.23

    Auf 21.2.23 aktualisieren

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 20.0.0, < 20.3.31

    Auf 20.3.31 aktualisieren

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≤ 19.2.25

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →