CVE-2026-101901
CVE-2026-101901 · Axios: Denial of Service via Unhandled 'error' Event in HTTP/2 ClientHttp2Session Initialization
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Axios is a promise-based HTTP client for the browser and Node.js. From 1.13.0 until 1.20.0, Http2Sessions does not install adequate error handling for a ClientHttp2Session during Axios HTTP/2 session initialization or reuse. A request uses httpVersion: 2 and the ClientHttp2Session emits an error during session initialization or reuse. The unhandled session error escapes normal Promise rejection handling. The uncaught error can terminate the Node.js process and cause denial of service. This issue is fixed in version 1.20.0.
CVSS 8.2 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
axios
- Softwareversionen
- >= 1.13.0, < 1.20.0: Betroffen
Keine Korrektur veröffentlicht
node-axios Debian:13
- Softwareversionen
- 1.11.0+dfsg-1
- 1.12.1+dfsg-1
- 1.13.1+dfsg-1
- 1.13.2+dfsg-1
- 1.14.0+dfsg-1
- 1.15.0-1
- 1.15.2-1
- 1.16.0-1
- 1.18.0-1
- 1.19.0-1
- 1.20.0-1
- 1.8.4+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-axios Debian:14
- Softwareversionen
- 1.11.0+dfsg-1
- 1.12.1+dfsg-1
- 1.13.1+dfsg-1
- 1.13.2+dfsg-1
- 1.14.0+dfsg-1
- 1.15.0-1
- 1.15.2-1
- 1.16.0-1
- 1.18.0-1
- 1.19.0-1
- 1.8.4+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.20.0-1
Auf 1.20.0-1 aktualisieren
axios npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.13.0, < 1.20.0
Auf 1.20.0 aktualisieren
node-axios Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 0.19.0+dfsg-2
- 0.19.0+dfsg-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-axios Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.21.1+dfsg-1
- 0.23.0+dfsg-2
- 0.24.0+dfsg-1
- 0.25.0+dfsg-2
- 0.26.0+dfsg-1
- 0.26.0+dfsg-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-axios Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 1.2.1+dfsg-1
- 1.5.1+dfsg-1
- 1.6.2+dfsg-1
- 1.6.8+dfsg-2
- 1.6.8+dfsg-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-axios Ubuntu:26.10
- Softwareversionen
- 1.13.2+dfsg-1build1
- 1.16.0-1
- 1.18.0-1
- 1.19.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-axios Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 1.11.0+dfsg-1
- 1.12.1+dfsg-1
- 1.13.2+dfsg-1build1
- 1.13.2+dfsg-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht