CVE-2026-101918
CVE-2026-101918 · PyJWT: Unauthenticated RecursionError DoS in pre-verification payload parse (PyJWKClient.get_signing_key_from_jwt / verify_signature=False)
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
PyJWT is a Python implementation of JSON Web Token standards. From 2.0.0a1 until 2.15.0, PyJWT PyJWKClient.get_signing_key_from_jwt is affected because payload parser catches ValueError but not RecursionError. This occurs when an attacker-controlled recursively nested payload reaches json.loads. As a result, documented PyJWT exception handling does not contain the failure. Consequently, an unauthenticated request can raise an exception that may produce an HTTP 500 response. The advisory-defined affected implementation also includes jwt/api_jwt.py, verify_signature=False. This issue is fixed in version 2.15.0.
CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pyjwt
- Softwareversionen
- >= 2.0.0a1, < 2.15.0: Betroffen
Keine Korrektur veröffentlicht
pyjwt Debian:12
- Softwareversionen
- 2.10.1-1
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- 2.6.0-1
- 2.6.0-1+deb12u1
- 2.7.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyjwt Debian:13
- Softwareversionen
- 2.10.1-2
- 2.10.1-2+deb13u1
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyjwt Debian:14
- Softwareversionen
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.15.0-1
Auf 2.15.0-1 aktualisieren
pyjwt PyPI
- Softwareversionen
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.1
- 2.1.0
- 2.10.0
- 2.10.1
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.14.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0a1, < 2.15.0
Auf 2.15.0 aktualisieren
pyjwt Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.0.0-0ubuntu1
- 1.3.0-1
- 1.3.0-1ubuntu0.1
- 1.3.0-1ubuntu0.1+esm1
- 1.3.0-1ubuntu0.1+esm2
- 1.3.0-1ubuntu0.1+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.3.0-1ubuntu0.1+esm4
Auf 1.3.0-1ubuntu0.1+esm4 aktualisieren
pyjwt Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.4.2-1.1
- 1.5.3+ds1-1
- 1.5.3+ds1-1ubuntu0.1
- 1.5.3+ds1-1ubuntu0.1+esm1
- 1.5.3+ds1-1ubuntu0.1+esm2
- 1.5.3+ds1-1ubuntu0.1+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1+esm4
Auf 1.5.3+ds1-1ubuntu0.1+esm4 aktualisieren
pyjwt Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.7.0-2
- 1.7.1-1
- 1.7.1-2ubuntu1
- 1.7.1-2ubuntu2
- 1.7.1-2ubuntu2.1
- 1.7.1-2ubuntu2.1+esm1
- 1.7.1-2ubuntu2.1+esm2
- 1.7.1-2ubuntu2.1+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.7.1-2ubuntu2.1+esm4
Auf 1.7.1-2ubuntu2.1+esm4 aktualisieren
pyjwt Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- 2.3.0-1ubuntu0.1
- 2.3.0-1ubuntu0.2
- 2.3.0-1ubuntu0.3
- 2.3.0-1ubuntu0.4
- 2.3.0-1ubuntu0.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.0-1ubuntu0.6
Auf 2.3.0-1ubuntu0.6 aktualisieren
pyjwt Ubuntu:24.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.7.0-1ubuntu0.1
- 2.7.0-1ubuntu0.2
- 2.7.0-1ubuntu0.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.0-1ubuntu0.4
Auf 2.7.0-1ubuntu0.4 aktualisieren
pyjwt Ubuntu:26.10
- Softwareversionen
- 2.10.1-4ubuntu1
- 2.12.1-1
- 2.13.0-1
- 2.13.0-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.13.0-1ubuntu1.1
Auf 2.13.0-1ubuntu1.1 aktualisieren
pyjwt Ubuntu:26.04:LTS
- Softwareversionen
- 2.10.1-2
- 2.10.1-3
- 2.10.1-3build1
- 2.10.1-4
- 2.10.1-4ubuntu1
- 2.10.1-4ubuntu1.1
- 2.10.1-4ubuntu1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.10.1-4ubuntu1.3
Auf 2.10.1-4ubuntu1.3 aktualisieren