p PatchFirst

CVE-2026-102278

CVE-2026-102278 · brace-expansion: DoS via uncontrolled recursion on nested brace groups causing stack exhaustion

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per nesting level at comma-member and single-set expansion sites, exhausting the native stack before output limits can apply and potentially terminating the Node.js process. expand_ performs uncontrolled recursion for nested brace alternatives and single-part sets. deeply nested brace groups supplied as an untrusted pattern. expand_ is affected. expand is affected. Comma members is affected. Single set is affected. native stack exhaustion during nested sub-expansion. process-terminating denial of service. This issue is fixed in versions 1.1.20, 2.1.6, 3.0.8, and 5.0.11.

CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • brace-expansion

    Softwareversionen
    • >= 4.0.0, < 5.0.11: Betroffen
    • >= 3.0.0, < 3.0.8: Betroffen
    • >= 2.0.0, < 2.1.6: Betroffen
    • < 1.1.20: Betroffen

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:12

    Softwareversionen
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:13

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:14

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.7+~1.1.2-1

    Auf 2.1.7+~1.1.2-1 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 5.0.11

    Auf 5.0.11 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.0.8

    Auf 3.0.8 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.1.6

    Auf 2.1.6 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.1.20

    Auf 1.1.20 aktualisieren

  • node-brace-expansion Ubuntu:18.04:LTS

    Softwareversionen
    • 1.1.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:20.04:LTS

    Softwareversionen
    • 1.1.8-1
    • 1.1.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:22.04:LTS

    Softwareversionen
    • 2.0.0-1
    • 2.0.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:24.04:LTS

    Softwareversionen
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.10

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.04:LTS

    Softwareversionen
    • 2.0.1+~1.1.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →