CVE-2026-102422
CVE-2026-102422 · shell-quote `quote()` command injection via a line terminator in a token after a `{ comment }` token
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
shell-quote's `quote()` function emits a `{ comment }` token as `#` followed by its text, which comments out the rest of the shell line, including the opening quote of any later string token. A line terminator (\n, \r, U+2028, U+2029) in that later string therefore ends the comment, and the rest of the string is parsed as shell input: `quote(['echo', 'ok', { comment: 'x' }, 'a\nid;#'])` runs `id` in sh, bash, dash, ksh and zsh. `parse()` emits a comment token for a `#` in the middle of a word (for example `http://example.com/#frag`), so callers that combine `parse()` output with another untrusted string, such as `quote(parse(untrustedCommand).concat(untrustedArg))`, are affected. The fix for CVE-2026-9277 rejected line terminators in the comment's own text, but not in the tokens after it. Fixed in 1.11.0: `quote()` throws a `TypeError` when a string after a `{ comment }` token contains a line terminator.
CVSS 9.2 · Kritisch · EPSS 0,4% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
shell-quote
- Softwareversionen
- ≥ 1.8.4, < 1.11.0: Betroffen (semver)
Auf 1.11.0 aktualisieren
node-shell-quote Debian:12
- Softwareversionen
- 1.10.0-1
- 1.12.0-1
- 1.7.4+~1.7.1-1
- 1.7.4+~1.7.1-1+deb12u1
- 1.7.4+~1.7.1-2
- 1.8.3+~1.7.5-1
- 1.8.4+~1.7.5-1
- 1.9.0+~1.7.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-shell-quote Debian:13
- Softwareversionen
- 1.7.4+~1.7.1-1
- 1.7.4+~1.7.1-1+deb13u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.7.4+~1.7.1-1+deb13u2
Auf 1.7.4+~1.7.1-1+deb13u2 aktualisieren
node-shell-quote Debian:14
- Softwareversionen
- 1.10.0-1
- 1.7.4+~1.7.1-1
- 1.7.4+~1.7.1-2
- 1.8.3+~1.7.5-1
- 1.8.4+~1.7.5-1
- 1.9.0+~1.7.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.12.0-1
Auf 1.12.0-1 aktualisieren
shell-quote npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.8.4, < 1.11.0
Auf 1.11.0 aktualisieren
node-shell-quote Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.6.1+20160617-git72fb5a8ce29b-1
- 1.6.1+20160617-git72fb5a8ce29b-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-shell-quote Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.7.3+~1.7.1-1
- 1.7.3+~1.7.1-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-shell-quote Ubuntu:24.04:LTS
- Softwareversionen
- 1.7.4+~1.7.1-1
- 1.7.4+~1.7.1-1ubuntu0.24.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-shell-quote Ubuntu:26.10
- Softwareversionen
- 1.8.3+~1.7.5-1
- 1.9.0+~1.7.5-1
- 1.10.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-shell-quote Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 1.7.4+~1.7.1-1
- 1.8.3+~1.7.5-1
- 1.8.3+~1.7.5-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht