CVE-2026-105315
CVE-2026-105315 · django-haystack more_like_this Template Tag elasticsearch_backend.py _to_python eval injection
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability has been found in django-haystack up to 3.3.0. Affected is the function _to_python of the file haystack/backends/elasticsearch_backend.py of the component more_like_this Template Tag Handler. Such manipulation of the argument result_class leads to improper neutralization of directives in dynamically evaluated code. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.4.0 is able to address this issue. The name of the patch is eb05f193c9771a68dcc8cfac6674a0d48a52ee9d. It is suggested to upgrade the affected component.
CVSS 5.1 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
django-haystack
- Softwareversionen
- 3.0: Betroffen
- 3.1: Betroffen
- 3.2: Betroffen
- 3.3.0: Betroffen
- 3.4.0: Nicht betroffen
Auf 3.4.0 aktualisieren
django-haystack Debian:12
- Softwareversionen
- 3.2.1-1
- 3.3.0-1
- 3.3.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Debian:13
- Softwareversionen
- 3.3.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Debian:14
- Softwareversionen
- 3.3.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack PyPI
- Softwareversionen
- 1.0.0-final
- 1.0.0-rc1
- 1.0.0b
- 1.0.1-final
- 1.0.2-final
- 1.1.0
- 1.2.0
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 2.0.0
- 2.1.0
- 2.2.0
- 2.2.1
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.0rc1
- 2.4.0rc2
- 2.4.1
- 2.5.0
- 2.5.1
- 2.5.dev0
- 2.5.dev1
- 2.5.dev2
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.dev0
- 2.7.dev1
- 2.8.0
- 2.8.1
- 3.0
- 3.0b1
- 3.0b2
- 3.1.0
- 3.1.1
- 3.2.0
- 3.2.1
- 3.2.dev0
- 3.3.0
- 3.3b2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.4.0
Auf 3.4.0 aktualisieren
django-haystack Ubuntu:16.04:LTS
- Softwareversionen
- 2.4.0-2
- 2.4.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Ubuntu:18.04:LTS
- Softwareversionen
- 2.6.1-1
- 2.7.0-1
- 2.8.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Ubuntu:20.04:LTS
- Softwareversionen
- 2.8.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Ubuntu:22.04:LTS
- Softwareversionen
- 3.0-1
- 3.1.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Ubuntu:24.04:LTS
- Softwareversionen
- 3.2.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Ubuntu:26.10
- Softwareversionen
- 3.3.0-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
django-haystack Ubuntu:26.04:LTS
- Softwareversionen
- 3.3.0-2
- 3.3.0-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://vuldb.com/vuln/413523
- https://vuldb.com/vuln/413523/cti
- https://vuldb.com/cve/CVE-2026-105315
- https://vuldb.com/submit/978642
- https://github.com/django-haystack/django-haystack/security/advisories/GHSA-r3hx-x5rh-p9vv
- https://github.com/django-haystack/django-haystack/commit/eb05f193c9771a68dcc8cfac6674a0d48a52ee9d
- https://github.com/django-haystack/django-haystack/releases/tag/v3.4.0
- https://github.com/django-haystack/django-haystack/
- https://nvd.nist.gov/vuln/detail/CVE-2026-105315