p PatchFirst

CVE-2026-105800

CVE-2026-105800 · i18next-http-backend incomplete URL validation permits SSRF

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

i18next-http-backend is a backend layer for i18next that loads translation resources in Node.js, browsers, and Deno. Prior to 4.0.2, attacker-controlled language or namespace values interpolated into a custom loadPath or addPath that begins directly with {{lng}} or {{ns}} can make colon-based input become an absolute URL or, in browsers, make a double-slash namespace become a protocol-relative URL. The resulting request can leave the intended origin and cause URL injection or server-side request forgery. The default /locales/{{lng}}/{{ns}}.json template and templates with a leading path or origin are not affected because the placeholder does not occupy the URL's structural beginning. This issue is fixed in version 4.0.2.

CVSS 3.7 · Niedrig · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • i18next-http-backend

    Softwareversionen
    • < 4.0.2: Betroffen

    Keine Korrektur veröffentlicht

  • node-i18next-http-backend Debian:12

    Softwareversionen
    • 2.1.1-1
    • 2.4.1+ds-1
    • 2.4.1+ds-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-i18next-http-backend Debian:13

    Softwareversionen
    • 2.4.1+ds-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-i18next-http-backend Debian:14

    Softwareversionen
    • 2.4.1+ds-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • i18next-http-backend npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.0.2

    Auf 4.0.2 aktualisieren

  • node-i18next-http-backend Ubuntu:22.04:LTS

    Softwareversionen
    • 1.0.21+dfsg-1
    • 1.3.1+dfsg-2
    • 1.3.1+dfsg-3
    • 1.3.1+dfsg-4
    • 1.3.2+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-i18next-http-backend Ubuntu:24.04:LTS

    Softwareversionen
    • 2.1.1-1
    • 2.4.1+ds-2
    • 2.4.1+ds-2build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-i18next-http-backend Ubuntu:26.10

    Softwareversionen
    • 2.4.1+ds-2build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-i18next-http-backend Ubuntu:26.04:LTS

    Softwareversionen
    • 2.4.1+ds-2build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →