CVE-2026-106443
CVE-2026-106443 · WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
WeasyPrint helps web developers to create PDF documents. Prior to 70.0, the image-loading path in weasyprint/images.py passes fetched image bytes from HTML img URLs, CSS image values, SVG image references, and data URIs to Pillow's generic image dispatcher without excluding EPS or PostScript formats. On hosts with Ghostscript installed, Pillow EpsImagePlugin invokes the interpreter for attacker-controlled PostScript, which can produce interpreter-permitted effects and can lead to remote code execution when the installed Ghostscript version has a usable sandbox bypass. Hosts without Ghostscript do not reach this rasterization path. This issue is fixed in version 70.0.
CVSS 8.8 · Hoch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
weasyprint
- Softwareversionen
- < 70.0: Betroffen
Keine Korrektur veröffentlicht
weasyprint Debian:12
- Softwareversionen
- 57.2-1
- 59.0-1
- 60.2-1
- 61.0-1
- 61.1-1
- 61.2-1
- 61.2-2
- 62.0-1
- 62.1-1
- 62.2-1
- 62.3-1
- 67.0-1
- 69.0-1
- 69.0-2
- 70.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
weasyprint Debian:13
- Softwareversionen
- 62.3-1
- 67.0-1
- 69.0-1
- 69.0-2
- 70.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
weasyprint Debian:14
- Softwareversionen
- 62.3-1
- 67.0-1
- 69.0-1
- 69.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 70.0-1
Auf 70.0-1 aktualisieren
weasyprint PyPI
- Softwareversionen
- 0.1
- 0.10
- 0.11
- 0.12
- 0.13
- 0.14
- 0.15
- 0.16
- 0.17
- 0.17.1
- 0.18
- 0.19
- 0.19.1
- 0.19.2
- 0.2
- 0.2.1
- 0.2.2
- 0.20
- 0.20.1
- 0.20.2
- 0.21
- 0.22
- 0.23
- 0.24
- 0.25
- 0.26
- 0.27
- 0.28
- 0.29
- 0.3
- 0.3.1
- 0.30
- 0.31
- 0.32
- 0.33
- 0.34
- 0.35
- 0.36
- 0.37
- 0.38
- 0.39
- 0.4
- 0.40
- 0.41
- 0.42
- 0.42.1
- 0.42.2
- 0.42.3
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.7.1
- 0.8
- 0.9
- 43
- 43rc1
- 43rc2
- 44
- 45
- 46
- 47
- 48
- 49
- 50
- 51
- 52
- 52.1
- 52.2
- 52.3
- 52.4
- 52.5
- 53.0
- 53.0b1
- 53.0b2
- 53.1
- 53.2
- 53.3
- 53.4
- 54.0
- 54.0b1
- 54.1
- 54.2
- 54.3
- 55.0
- 55.0b1
- 56.0
- 56.0b1
- 56.1
- 57.0
- 57.0b1
- 57.1
- 57.2
- 58.0
- 58.0b1
- 58.1
- 59.0
- 59.0b1
- 60.0
- 60.1
- 60.2
- 61.0
- 61.1
- 61.2
- 62.0
- 62.1
- 62.2
- 62.3
- 63.0
- 63.1
- 64.0
- 64.1
- 65.0
- 65.1
- 66.0
- 67.0
- 68.0
- 68.1
- 69.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 70.0
Auf 70.0 aktualisieren
weasyprint Ubuntu:20.04:LTS
- Softwareversionen
- 50-2
- 51-1
- 51-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
weasyprint Ubuntu:22.04:LTS
- Softwareversionen
- 51-2
- 51-3
- 53.4-1
- 54.0-1
- 54.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
weasyprint Ubuntu:24.04:LTS
- Softwareversionen
- 59.0-1
- 60.2-1
- 61.0-1
- 61.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
weasyprint Ubuntu:26.10
- Softwareversionen
- 67.0-1
- 69.0-1
- 69.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
weasyprint Ubuntu:26.04:LTS
- Softwareversionen
- 62.3-1
- 62.3-1build1
- 67.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht