p PatchFirst

CVE-2026-106446

CVE-2026-106446 · Handlebars: JavaScript Injection via AST Type Confusion in compile (Program.blockParams)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Handlebars provides the power necessary to let users build semantic templates. From 4.0.0 until 4.7.10, Handlebars.compile() and Handlebars.precompile() accept pre-parsed AST objects while validating only selected PathExpression, NumberLiteral, and BooleanLiteral values. This issue bypasses the AST validation introduced in version 4.7.9 for CVE-2026-33937. An attacker who can supply an object instead of a template string can place JavaScript expressions in unchecked values such as Program.blockParams.length, a non-PathExpression parameter depth, a non-string StringLiteral.value, or a non-string PathExpression.original. The compiler emits those values into generated JavaScript, causing code execution in the server process when compile output renders or wherever precompile output is loaded. Applications that pass only template strings are not affected. This issue is fixed in version 4.7.10.

CVSS 9.8 · Kritisch · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • handlebars.js

    Softwareversionen
    • >= 4.0.0, < 4.7.10: Betroffen

    Keine Korrektur veröffentlicht

  • node-handlebars Debian:12

    Softwareversionen
    • 3:4.7.10-1
    • 3:4.7.7+~4.1.0-1
    • 3:4.7.9-1
    • 3:4.7.9-2
    • 3:4.7.9-3
    • 3:4.7.9-4
    • 3:4.7.9-5
    • 3:4.7.9-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Debian:13

    Softwareversionen
    • 3:4.7.10-1
    • 3:4.7.7+~4.1.0-1
    • 3:4.7.9-1
    • 3:4.7.9-2
    • 3:4.7.9-3
    • 3:4.7.9-4
    • 3:4.7.9-5
    • 3:4.7.9-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Debian:14

    Softwareversionen
    • 3:4.7.7+~4.1.0-1
    • 3:4.7.9-1
    • 3:4.7.9-2
    • 3:4.7.9-3
    • 3:4.7.9-4
    • 3:4.7.9-5
    • 3:4.7.9-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3:4.7.10-1

    Auf 3:4.7.10-1 aktualisieren

  • handlebars npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.7.10

    Auf 4.7.10 aktualisieren

  • ruby-handlebars-assets Ubuntu:16.04:LTS

    Softwareversionen
    • 0.15-2
    • 2:0.20.2-2
    • 2:0.21.0-2
    • 2:0.21.0-3
    • 2:0.21.0-4
    • 2:0.21.0-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Ubuntu:18.04:LTS

    Softwareversionen
    • 3:4.0.10-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby-handlebars-assets Ubuntu:18.04:LTS

    Softwareversionen
    • 2:0.23.1-1
    • 2:0.23.2-2
    • 2:0.23.2+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Ubuntu:20.04:LTS

    Softwareversionen
    • 3:4.1.0-1
    • 3:4.5.3-1
    • 3:4.7.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby-handlebars-assets Ubuntu:20.04:LTS

    Softwareversionen
    • 2:0.23.3+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Ubuntu:22.04:LTS

    Softwareversionen
    • 3:4.7.6+~4.1.0-2
    • 3:4.7.7+~4.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby-handlebars-assets Ubuntu:22.04:LTS

    Softwareversionen
    • 2:0.23.8+dfsg-3
    • 2:0.23.8+dfsg-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Ubuntu:24.04:LTS

    Softwareversionen
    • 3:4.7.7+~4.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby-handlebars-assets Ubuntu:24.04:LTS

    Softwareversionen
    • 2:0.23.9+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Ubuntu:26.10

    Softwareversionen
    • 3:4.7.7+~4.1.0-1
    • 3:4.7.9-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-handlebars Ubuntu:26.04:LTS

    Softwareversionen
    • 3:4.7.7+~4.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →