CVE-2026-107294
CVE-2026-107294 · Pydantic AI: Unbounded memory use when downloading remote content via web_fetch or FileUrl
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 1.77.0 until 1.107.2 and 2.24.0, web_fetch_tool, the WebFetch local fallback, and remote FileUrl media downloads buffer the complete HTTP response body before enforcing content-size controls. An attacker-influenced URL can stream an arbitrarily large response that exhausts process memory and crashes the worker; affected media types include ImageUrl, DocumentUrl, VideoUrl, and AudioUrl. SSRF protections remain effective, and the impact is limited to availability. This issue is fixed in versions 1.107.2 and 2.24.0.
CVSS 6.5 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
pydantic-ai
- Softwareversionen
- >= 1.77.0, < 1.107.2: Betroffen
- >= 2.0.0b1, < 2.24.0: Betroffen
Keine Korrektur veröffentlicht
pydantic-ai-slim
- Softwareversionen
- >= 1.77.0, < 1.107.2: Betroffen
- >= 2.0.0b1, < 2.24.0: Betroffen
Keine Korrektur veröffentlicht
pydantic-ai PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.77.0, < 1.107.2
Auf 1.107.2 aktualisieren
pydantic-ai PyPI
- Softwareversionen
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0b1, < 2.24.0
Auf 2.24.0 aktualisieren
pydantic-ai-slim PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.77.0, < 1.107.2
Auf 1.107.2 aktualisieren
pydantic-ai-slim PyPI
- Softwareversionen
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0b1, < 2.24.0
Auf 2.24.0 aktualisieren
pydantic-ai PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.77.0, < 1.107.2 ∪ ≥ 2.0.0b1, < 2.24.0
Auf 1.107.2 aktualisieren; Auf 2.24.0 aktualisieren
pydantic-ai-slim PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.106.0
- 1.107.0
- 1.107.1
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- 2.0.0b6
- 2.0.0b7
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.16.0
- 2.17.0
- 2.18.0
- 2.19.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.77.0, < 1.107.2 ∪ ≥ 2.0.0b1, < 2.24.0
Auf 1.107.2 aktualisieren; Auf 2.24.0 aktualisieren
Originalquellen
- https://github.com/pydantic/pydantic-ai/security/advisories/GHSA-v2xh-2vp8-57h8
- https://github.com/pydantic/pydantic-ai/pull/7141
- https://github.com/pydantic/pydantic-ai/pull/7308
- https://github.com/pydantic/pydantic-ai/commit/7a64d049c3f5271a975cd1d64b2fa876d83ede1d
- https://github.com/pydantic/pydantic-ai/commit/e3824a58c82864ed26afb2887619834a4eb86cc8
- https://github.com/pydantic/pydantic-ai/releases/tag/v1.107.2
- https://github.com/pydantic/pydantic-ai/releases/tag/v2.24.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-107294