p PatchFirst

CVE-2026-108357

CVE-2026-108357 · PhpSpreadsheet: XmlScanner Bypass via Double-Encoded unentity() TOCTOU Allows XXE and Denial of Service

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. From 3.3.0 until 3.10.8 and 5.10.0, Reader\Xml passes stored SpreadsheetML XML through XmlScanner::scan in Xml::canRead and Xml::trySimpleXMLLoadStringPrivate, while Xml::unentity decodes numeric entities only after each DOCTYPE pattern check. A double-encoded less-than character is reduced by the first callback to another encoded character and by the second callback to a literal less-than sign, so SimpleXML receives an unchecked DOCTYPE and entity declaration. Processing attacker-controlled SpreadsheetML XML can cause entity-expansion denial of service and can permit local file access or SSRF on PHP before 8.0 or when LIBXML_NOENT is enabled. This issue is fixed in versions 3.10.8 and 5.10.0.

CVSS 8.8 · Hoch · EPSS 0,4% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • phpspreadsheet

    Softwareversionen
    • >= 3.3.0, < 3.10.8: Betroffen
    • >= 4.0.0, < 5.10.0: Betroffen

    Keine Korrektur veröffentlicht

  • phpoffice/phpspreadsheet Packagist

    Softwareversionen
    • 4.0.0
    • 4.1.0
    • 4.2.0
    • 4.3.0
    • 4.3.1
    • 4.4.0
    • 4.5.0
    • 5.0.0
    • 5.1.0
    • 5.2.0
    • 5.3.0
    • 5.4.0
    • 5.5.0
    • 5.6.0
    • 5.7.0
    • 5.8.0
    • 5.8.1
    • 5.9.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.0.0, < 5.10.0

    Auf 5.10.0 aktualisieren

  • phpoffice/phpspreadsheet Packagist

    Softwareversionen
    • 3.10.0
    • 3.10.1
    • 3.10.2
    • 3.10.3
    • 3.10.4
    • 3.10.5
    • 3.10.6
    • 3.10.7
    • 3.3.0
    • 3.4.0
    • 3.5.0
    • 3.6.0
    • 3.7.0
    • 3.8.0
    • 3.9.0
    • 3.9.1
    • 3.9.2
    • 3.9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.3.0, < 3.10.8

    Auf 3.10.8 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →