p PatchFirst

CVE-2026-110810

CVE-2026-110810 · ggml-org whisper.cpp Model Loader whisper_model_load out-of-bounds

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was detected in ggml-org whisper.cpp up to 1.9.4. This affects the function whisper_model_load of the file src/whisper.cpp of the component Model Loader. Performing a manipulation of the argument ttype results in out-of-bounds read. The attack must be initiated from a local position. The exploit is now public and may be used. Upgrading to version 1.9.5 is able to mitigate this issue. The patch is named 60c0be6ac8fa71b1a2ae2dd938a31a34a508e774. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

CVSS 2.4 · Niedrig · EPSS 0,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • whisper.cpp

    Softwareversionen
    • 1.9.0: Betroffen
    • 1.9.1: Betroffen
    • 1.9.2: Betroffen
    • 1.9.3: Betroffen
    • 1.9.4: Betroffen
    • 1.9.5: Nicht betroffen

    Auf 1.9.5 aktualisieren

  • whisper.cpp Debian:14

    Softwareversionen
    • 1.7.6+dfsg-1
    • 1.8.2+dfsg-1
    • 1.8.2+dfsg-2
    • 1.8.2+dfsg-3
    • 1.8.2+dfsg-4
    • 1.8.2+dfsg-5
    • 1.8.3+dfsg-1
    • 1.8.3+dfsg-2
    • 1.8.3+dfsg-2~exp1
    • 1.8.3+dfsg-2~exp2
    • 1.8.4+dfsg-1
    • 1.8.6+dfsg-1
    • 1.8.6+dfsg-2
    • 1.9.1+dfsg1-1
    • 1.9.2+dfsg-1
    • 1.9.3+dfsg-1
    • 1.9.3+dfsg-1~exp1
    • 1.9.4+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.9.5+dfsg-1

    Auf 1.9.5+dfsg-1 aktualisieren

  • whisper.cpp Ubuntu:26.10

    Softwareversionen
    • 1.8.3+dfsg-2
    • 1.8.4+dfsg-1
    • 1.8.6+dfsg-1
    • 1.8.6+dfsg-2build1
    • 1.9.1+dfsg1-1
    • 1.9.2+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • whisper.cpp Ubuntu:26.04:LTS

    Softwareversionen
    • 1.8.3+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →