p PatchFirst

CVE-2026-112085

CVE-2026-112085 · webpack-dev-server vulnerable to cross-origin WebSocket access via proxied upgrades

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

webpack-dev-server is a development server that provides live reloading for webpack projects. In versions before 5.2.7 and in version 6.0.0, when a proxy entry is configured to forward WebSockets, the server forwards non-HMR WebSocket upgrade requests to the proxy target without validating the Host or Origin headers, so the allowedHosts protection does not apply to those proxied upgrades. A malicious web page visited by a developer can open a cross-origin WebSocket through the dev server and read from and write to the proxied backend, even when the server is bound to loopback. The issue is fixed in webpack-dev-server 5.2.7 and 6.1.0, where proxied WebSocket upgrades pass the same Host and Origin validation as the HMR WebSocket, and users should upgrade to one of those versions or later. As a workaround, omit WebSocket forwarding from proxy entries that do not need it and scope the proxy to specific paths.

CVSS 8.2 · Hoch · EPSS 0,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webpack-dev-server

    Softwareversionen
    • ≥ 0, < 5.2.7: Betroffen (semver)
    • 5.2.7: Nicht betroffen (semver)
    • ≥ 6.0.0, < 6.1.0: Betroffen (semver)
    • 6.1.0: Nicht betroffen (semver)

    Auf 5.2.7 aktualisieren; Auf 6.1.0 aktualisieren

  • node-webpack Ubuntu:18.04:LTS

    Softwareversionen
    • 3.5.6-1build3
    • 3.5.6-1build4
    • 3.5.6-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:20.04:LTS

    Softwareversionen
    • 4.7.0-3
    • 4.30.0-7
    • 4.30.0-9
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:22.04:LTS

    Softwareversionen
    • 4.43.0-6build4
    • 4.43.0-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:24.04:LTS

    Softwareversionen
    • 5.76.1+dfsg1+~cs17.16.16-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:26.10

    Softwareversionen
    • 5.105.4+dfsg1+~cs15.13.23-2
    • 5.108.0+dfsg1+~cs14.7.20-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-webpack Ubuntu:26.04:LTS

    Softwareversionen
    • 5.97.1+dfsg1+~cs11.18.27-3
    • 5.97.1+dfsg1+~cs11.18.27-4
    • 5.105.4+dfsg1+~cs15.13.23-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →