p PatchFirst

CVE-2026-112942

CVE-2026-112942 · launch-editor: `fs.existsSync()` existence check can be bypassed on Windows

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, launch-editor-middleware processes an attacker-controlled Windows file argument where the file argument ends in a parent-directory component plus a line-and-column suffix: the path is resolved while the suffix is still present, and launch-editor removes the suffix before its existsSync check, leaving the existing parent directory for existsSync and allowing the attacker-controlled file argument to pass filename existence validation without requiring the malicious filename to exist. The bypass can lead to OS command injection when combined with the separately described Windows percent-expansion flaw. This issue is fixed in version 2.14.2.

CVSS 7.5 · Hoch · EPSS 1,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • launch-editor

    Softwareversionen
    • < 2.14.2: Betroffen

    Keine Korrektur veröffentlicht

  • vite

    Softwareversionen
    • >= 8.3.0, < 8.3.3: Betroffen
    • >= 8.2.0, < 8.2.4: Betroffen
    • >= 8.0.0, < 8.1.6: Betroffen
    • >= 7.0.0, < 7.3.7: Betroffen
    • < 6.4.4: Betroffen

    Keine Korrektur veröffentlicht

  • vite-plus

    Softwareversionen
    • < 1.1.0: Betroffen

    Keine Korrektur veröffentlicht

  • launch-editor npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.14.2

    Auf 2.14.2 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.3.0, < 8.3.3

    Auf 8.3.3 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.2.0, < 8.2.4

    Auf 8.2.4 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.1.6

    Auf 8.1.6 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0, < 7.3.7

    Auf 7.3.7 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: < 6.4.4

    Auf 6.4.4 aktualisieren

  • vite-plus npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.1.0

    Auf 1.1.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →