p PatchFirst

CVE-2026-112945

CVE-2026-112945 · Vite: Cross origin script execution through Vite custom middleware

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vite is a frontend tooling framework for JavaScript. Prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they pass an unchanged browser request URL to server.transformIndexHtml. getHtmlFilename uses the query-bearing request URL to resolve an existing local file while preserving attacker-supplied leading slashes in the generated proxy module URL. If the transformed HTML contains an inline module script and a victim browser loads the crafted development-server page, the leading double slash makes the browser fetch and execute an attacker-controlled module in the Vite-served page. This execution can expose sensitive page data or permit critical actions available to the affected application. This issue is fixed in versions 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3.

CVSS 2.1 · Niedrig · EPSS 0,6% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • vite

    Softwareversionen
    • >= 8.3.0, < 8.3.3: Betroffen
    • >= 8.2.0, < 8.2.4: Betroffen
    • >= 8.0.0, < 8.1.6: Betroffen
    • >= 7.0.0, < 7.3.7: Betroffen
    • < 6.4.4: Betroffen

    Keine Korrektur veröffentlicht

  • vite-plus

    Softwareversionen
    • < 1.1.0: Betroffen

    Keine Korrektur veröffentlicht

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.3.0, < 8.3.3

    Auf 8.3.3 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.2.0, < 8.2.4

    Auf 8.2.4 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.1.6

    Auf 8.1.6 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0, < 7.3.7

    Auf 7.3.7 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: < 6.4.4

    Auf 6.4.4 aktualisieren

  • vite-plus npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.1.0

    Auf 1.1.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →