CVE-2026-114138
CVE-2026-114138 · Django REST framework: Accept header with many large quoted parameters burns ~19s of CPU per request in content negotiation
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Django REST framework is a toolkit for building Web APIs. Prior to 3.18.2, DefaultContentNegotiation.get_accept_list in rest_framework/negotiation.py accepts an unbounded number and aggregate size of Accept tokens, while select_renderer in that file repeatedly invokes _MediaType parsing from rest_framework/utils/mediatypes.py for each attacker-controlled token, every renderer, and forced 406 renegotiation. A remote unauthenticated client can send many distinct media types containing large quoted parameter values with numerous semicolons, causing Django's parameter parser and DRF's repeated parsing structure to consume disproportionate CPU. Requests to any reachable endpoint can pin synchronous workers for prolonged periods, and concurrent requests can make the service unavailable until the requests stop. This issue is fixed in version 3.18.2.
CVSS 7.5 · Hoch · EPSS 0,5% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
django-rest-framework
- Softwareversionen
- < 3.18.2: Betroffen
Keine Korrektur veröffentlicht
djangorestframework Debian:12
- Softwareversionen
- 3.14.0-2
- 3.14.0-2+deb12u1
- 3.15.1-1
- 3.15.1-2
- 3.15.2-1
- 3.15.2-2
- 3.16.0-1
- 3.16.1-1
- 3.16.1-3
- 3.16.1-4
- 3.17.1+ds1-1
- 3.17.1-1
- 3.18.1+ds1-1
- 3.18.3+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Debian:13
- Softwareversionen
- 3.16.0-1
- 3.16.1-1
- 3.16.1-3
- 3.16.1-4
- 3.17.1+ds1-1
- 3.17.1-1
- 3.18.1+ds1-1
- 3.18.3+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Debian:14
- Softwareversionen
- 3.16.0-1
- 3.16.1-1
- 3.16.1-3
- 3.16.1-4
- 3.17.1+ds1-1
- 3.17.1-1
- 3.18.1+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.18.3+ds1-1
Auf 3.18.3+ds1-1 aktualisieren
djangorestframework PyPI
- Softwareversionen
- 0.1
- 0.1.1
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.4.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.1.10
- 2.1.11
- 2.1.12
- 2.1.13
- 2.1.14
- 2.1.15
- 2.1.16
- 2.1.17
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.1.7
- 2.1.8
- 2.1.9
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.3.0
- 2.3.1
- 2.3.10
- 2.3.11
- 2.3.12
- 2.3.13
- 2.3.14
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 2.3.8
- 2.3.9
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.10.0
- 3.10.1
- 3.10.2
- 3.10.3
- 3.11.0
- 3.11.1
- 3.11.2
- 3.12.0
- 3.12.1
- 3.12.2
- 3.12.3
- 3.12.4
- 3.13.0
- 3.13.1
- 3.14.0
- 3.15.0
- 3.15.1
- 3.15.2
- 3.16.0
- 3.16.1
- 3.17.0
- 3.17.1
- 3.17.2
- 3.18.0
- 3.18.1
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.6.0
- 3.6.1
- 3.6.2
- 3.6.3
- 3.6.4
- 3.7.0
- 3.7.1
- 3.7.2
- 3.7.3
- 3.7.4
- 3.7.5
- 3.7.6
- 3.7.7
- 3.8.0
- 3.8.1
- 3.8.2
- 3.9.0
- 3.9.1
- 3.9.2
- 3.9.3
- 3.9.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.18.2
Auf 3.18.2 aktualisieren
djangorestframework Ubuntu:16.04:LTS
- Softwareversionen
- 2.4.3-2
- 3.3.1-1
- 3.3.2-1
- 3.3.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Ubuntu:18.04:LTS
- Softwareversionen
- 3.4.0-2
- 3.7.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Ubuntu:20.04:LTS
- Softwareversionen
- 3.9.0-2
- 3.10.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Ubuntu:22.04:LTS
- Softwareversionen
- 3.12.1-1
- 3.12.4-1
- 3.12.4-2
- 3.12.4-2ubuntu1
- 3.12.4-2.1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Ubuntu:24.04:LTS
- Softwareversionen
- 3.14.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Ubuntu:26.10
- Softwareversionen
- 3.16.1-3
- 3.16.1-4
- 3.17.1+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
djangorestframework Ubuntu:26.04:LTS
- Softwareversionen
- 3.16.1-1
- 3.16.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht