CVE-2026-114619
CVE-2026-114619 · Authlib: OpenID implicit grant checks raw scope instead of allowed scope before issuing ID tokens
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, OpenIDImplicitGrant.validate_authorization_request() checks the client-controlled raw request.payload.scope for openid after the parent grant has filtered allowed scopes into request.scope. A registered client permitted an ID token response type but not the openid scope can add openid to the request, obtain user consent, and receive a signed ID token containing the user's subject and allowed profile claims. Authorization code flow and deployments that allow openid for every client permitted an ID token response are not affected. In authlib/oidc/core/grants/implicit.py, OpenIDImplicitGrant.validate_authorization_request() checks request.payload.scope instead of the filtered request.scope. This issue is fixed in version 1.9.0.
CVSS 4.6 · Mittel · EPSS 0,2% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
authlib
- Softwareversionen
- < 1.9.0: Betroffen
Keine Korrektur veröffentlicht
python-authlib Debian:12
- Softwareversionen
- 1.2.0-1
- 1.2.0-1+deb12u1
- 1.2.0-1+deb12u2
- 1.2.1-1
- 1.3.0-1
- 1.3.0-2
- 1.3.0-3
- 1.3.1-1
- 1.3.2-1
- 1.3.2-2
- 1.4.0-1
- 1.4.1-1
- 1.5.0-1
- 1.5.1-1
- 1.5.2-1
- 1.6.0-1
- 1.6.1-1
- 1.6.3-1
- 1.6.4-1
- 1.6.5-1
- 1.6.6-1
- 1.6.7-1
- 1.6.8-1
- 1.6.9-1
- 1.7.0-1
- 1.7.2-1
- 1.7.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-authlib Debian:13
- Softwareversionen
- 1.6.0-1
- 1.6.0-1+deb13u1
- 1.6.1-1
- 1.6.3-1
- 1.6.4-1
- 1.6.5-1
- 1.6.6-1
- 1.6.7-1
- 1.6.8-1
- 1.6.9-1
- 1.7.0-1
- 1.7.2-1
- 1.7.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-authlib Debian:14
- Softwareversionen
- 1.6.0-1
- 1.6.1-1
- 1.6.3-1
- 1.6.4-1
- 1.6.5-1
- 1.6.6-1
- 1.6.7-1
- 1.6.8-1
- 1.6.9-1
- 1.7.0-1
- 1.7.2-1
- 1.7.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
authlib PyPI
- Softwareversionen
- 0.1
- 0.10
- 0.11
- 0.12
- 0.12.1
- 0.13
- 0.14
- 0.14.1
- 0.14.2
- 0.14.3
- 0.15
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.1rc0
- 0.2
- 0.2.1
- 0.3
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.7
- 0.8
- 0.9
- 1.0.0
- 1.0.0a1
- 1.0.0a2
- 1.0.0b1
- 1.0.0b2
- 1.0.0rc1
- 1.0.1
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.6.1
- 1.6.10
- 1.6.11
- 1.6.12
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7.0
- 1.7.1
- 1.7.2
- 1.8.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.0
Auf 1.9.0 aktualisieren
python-authlib Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.15.4-1
- 0.15.5-1
- 0.15.5-1ubuntu0.1~esm1
- 0.15.5-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-authlib Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 1.2.1-1
- 1.3.0-1
- 1.3.0-1ubuntu0.1~esm1
- 1.3.0-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-authlib Ubuntu:26.10
- Softwareversionen
- 1.6.7-1
- 1.7.2-1
- 1.7.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-authlib Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 1.6.0-1
- 1.6.5-1
- 1.6.6-1
- 1.6.7-1
- 1.6.7-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/authlib/authlib/security/advisories/GHSA-q686-2qmg-hqc7
- https://github.com/authlib/authlib/pull/945
- https://github.com/authlib/authlib/commit/e3bd41cb29dcfee434453b135ffb487884baeedf
- https://github.com/authlib/authlib/releases/tag/v1.9.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-114619