p PatchFirst

CVE-2026-115907

CVE-2026-115907 · zip: legacy Shrink/Reduce/Implode decoder: denial of service from attacker-controlled ZIP64 uncompressed size

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

zip is a zip library for Rust that supports reading and writing simple ZIP files. From 5.1.0 until 9.0.0, applications built with the legacy-zip feature can reserve output capacity from an attacker-controlled ZIP64 uncompressed size before validating the compressed stream. The ShrinkDecoder path in src/legacy/shrink.rs can panic with a capacity overflow during ZipArchive::extract, and the Reduce and Implode decoders contain the same unbounded preallocation pattern. An unhandled panic can terminate an archive-processing service. This issue is fixed in version 9.0.0.

CVSS 7.5 · Hoch · EPSS 0,4% · Öffentlicher Exploit

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • zip2

    Softwareversionen
    • >= 5.1.0, < 9.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • rust-zip Debian:12

    Softwareversionen
    • 0.6.3-3
    • 0.6.6-1
    • 0.6.6-2
    • 0.6.6-3
    • 0.6.6-4
    • 0.6.6-5
    • 2.5.0-1
    • 5.1.1+dfsg-1
    • 5.1.1-1
    • 5.1.1-2
    • 5.1.1-3
    • 5.1.1-4
    • 9.0.5+ds-1
    • 9.1.3+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rust-zip Debian:13

    Softwareversionen
    • 2.5.0-1
    • 5.1.1+dfsg-1
    • 5.1.1-1
    • 5.1.1-2
    • 5.1.1-3
    • 5.1.1-4
    • 9.0.5+ds-1
    • 9.1.3+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rust-zip Debian:14

    Softwareversionen
    • 2.5.0-1
    • 5.1.1+dfsg-1
    • 5.1.1-1
    • 5.1.1-2
    • 5.1.1-3
    • 5.1.1-4
    • 9.0.5+ds-1
    • 9.1.3+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rust-zip Ubuntu:20.04:LTS

    Softwareversionen
    • 0.5.0-1
    • 0.5.3-1
    • 0.5.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rust-zip Ubuntu:22.04:LTS

    Softwareversionen
    • 0.5.8-2
    • 0.5.13-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rust-zip Ubuntu:24.04:LTS

    Softwareversionen
    • 0.6.6-1
    • 0.6.6-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rust-zip Ubuntu:26.10

    Softwareversionen
    • 5.1.1-3
    • 5.1.1+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rust-zip Ubuntu:26.04:LTS

    Softwareversionen
    • 2.5.0-1
    • 5.1.1-2
    • 5.1.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →