p PatchFirst

CVE-2026-115919

CVE-2026-115919 · ONNX: Out-of-Bounds Read in RNN/GRU/LSTM Shape Inference (Old Opsets, Missing Rank Check)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to 1.22.0, RNNShapeInference_opset1_to_6() processes malformed RNN and LSTM nodes from opsets 1 through 6 and GRU nodes from opsets 3 through 6 without verifying that the first input has rank three. The function accesses dim(0) and dim(1) on an undersized protobuf shape, which can read outside the intended repeated field and terminate an application when onnx.shape_inference.infer_shapes() processes an untrusted model that can pass onnx.checker.check_model(). This issue is fixed in version 1.22.0.

CVSS 6.2 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • onnx

    Softwareversionen
    • < 1.22.0: Betroffen

    Keine Korrektur veröffentlicht

  • onnx Debian:12

    Softwareversionen
    • 1.12.0-2
    • 1.13.1-1
    • 1.13.1-2
    • 1.13.1-3
    • 1.14.1-1
    • 1.14.1-2
    • 1.14.1-2.1
    • 1.14.1-2.1~exp1
    • 1.16.1-1
    • 1.16.2-1
    • 1.17.0-1
    • 1.17.0-2
    • 1.17.0-3
    • 1.19.1-1~exp1
    • 1.20.0-1
    • 1.20.0-1~exp1
    • 1.20.0-3
    • 1.20.0-4
    • 1.20.0-5
    • 1.20.0-6
    • 1.21.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Debian:13

    Softwareversionen
    • 1.17.0-3
    • 1.19.1-1~exp1
    • 1.20.0-1
    • 1.20.0-1~exp1
    • 1.20.0-3
    • 1.20.0-4
    • 1.20.0-5
    • 1.20.0-6
    • 1.21.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Debian:14

    Softwareversionen
    • 1.17.0-3
    • 1.19.1-1~exp1
    • 1.20.0-1
    • 1.20.0-1~exp1
    • 1.20.0-3
    • 1.20.0-4
    • 1.20.0-5
    • 1.20.0-6
    • 1.21.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx PyPI

    Softwareversionen
    • 0.1
    • 0.2
    • 0.2.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.10.0
    • 1.10.1
    • 1.10.2
    • 1.11.0
    • 1.12.0
    • 1.13.0
    • 1.13.1
    • 1.14.0
    • 1.14.1
    • 1.15.0
    • 1.16.0
    • 1.16.1
    • 1.16.2
    • 1.17.0
    • 1.18.0
    • 1.19.0
    • 1.19.1
    • 1.19.1rc1
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.20.0
    • 1.20.0rc1
    • 1.20.0rc2
    • 1.20.1
    • 1.20.1rc1
    • 1.21.0
    • 1.21.0rc1
    • 1.21.0rc2
    • 1.21.0rc3
    • 1.21.0rc4
    • 1.22.0rc1
    • 1.22.0rc2
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    • 1.9.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.22.0

    Auf 1.22.0 aktualisieren

  • onnx Ubuntu:22.04:LTS

    Softwareversionen
    • 1.7.0+dfsg-3build1
    • 1.7.0+dfsg-3build2
    • 1.7.0+dfsg-3ubuntu1
    • 1.7.0+dfsg-3ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 1.13.1-3
    • 1.13.1-3build1
    • 1.14.1-2
    • 1.14.1-2.1
    • 1.14.1-2.1build1
    • 1.14.1-2.1build2
    • 1.14.1-2.1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Ubuntu:26.10

    Softwareversionen
    • 1.20.0-1
    • 1.20.0-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Ubuntu:26.04:LTS

    Softwareversionen
    • 1.17.0-3build1
    • 1.20.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →