CVE-2026-116577
CVE-2026-116577 · Tornado: Quadratic CPU usage when parsing HTTP headers with line folding
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Tornado is a Python web framework and asynchronous networking library. Prior to 6.6, Tornado's HTTP header parser accepts obsolete line folding and repeatedly concatenates short continuation lines, causing quadratic CPU consumption on the IOLoop thread. An unauthenticated client can submit a header block containing many obsolete line-folding continuations before application code runs, blocking other connections served by the process. The cost grows with max_header_size, and only availability is affected. This issue is fixed in version 6.6.
CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
tornado
- Softwareversionen
- < 6.6: Betroffen
Keine Korrektur veröffentlicht
python-tornado Debian:12
- Softwareversionen
- 6.2.0-3
- 6.2.0-3+deb12u1
- 6.2.0-3+deb12u2
- 6.2.0-3+deb12u3
- 6.2.0-3+deb12u4
- 6.3.2-1
- 6.4.0-1
- 6.4.0-2
- 6.4.1-1
- 6.4.1-2
- 6.4.1-3
- 6.4.2-1
- 6.4.2-2
- 6.4.2-3
- 6.5.2-1
- 6.5.2-2
- 6.5.2-3
- 6.5.4-0.1
- 6.5.4-1
- 6.5.5-1
- 6.5.5-2
- 6.5.5-3
- 6.5.5-4
- 6.5.5-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Debian:13
- Softwareversionen
- 6.4.2-3
- 6.4.2-3+deb13u1
- 6.4.2-3+deb13u2
- 6.5.2-1
- 6.5.2-2
- 6.5.2-3
- 6.5.4-0.1
- 6.5.4-1
- 6.5.5-1
- 6.5.5-2
- 6.5.5-3
- 6.5.5-4
- 6.5.5-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Debian:14
- Softwareversionen
- 6.4.2-3
- 6.5.2-1
- 6.5.2-2
- 6.5.2-3
- 6.5.4-0.1
- 6.5.4-1
- 6.5.5-1
- 6.5.5-2
- 6.5.5-3
- 6.5.5-4
- 6.5.5-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
tornado PyPI
- Softwareversionen
- 0.2
- 1.0
- 1.1
- 1.1.1
- 1.2
- 1.2.1
- 2.0
- 2.1
- 2.1.1
- 2.2
- 2.2.1
- 2.3
- 2.4
- 2.4.1
- 3.0
- 3.0.1
- 3.0.2
- 3.1
- 3.1.1
- 3.2
- 3.2.1
- 3.2.2
- 4.0
- 4.0.1
- 4.0.2
- 4.1
- 4.1b2
- 4.2
- 4.2.1
- 4.2b1
- 4.3
- 4.3b1
- 4.3b2
- 4.4
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4b1
- 4.5
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5b1
- 4.5b2
- 5.0
- 5.0.1
- 5.0.2
- 5.0a1
- 5.0b1
- 5.1
- 5.1.1
- 5.1b1
- 6.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.0.4
- 6.0a1
- 6.0b1
- 6.1
- 6.1b1
- 6.1b2
- 6.2
- 6.2b1
- 6.2b2
- 6.3
- 6.3.1
- 6.3.2
- 6.3.3
- 6.3b1
- 6.4
- 6.4.1
- 6.4.2
- 6.4b1
- 6.5
- 6.5.1
- 6.5.10
- 6.5.2
- 6.5.3
- 6.5.4
- 6.5.5
- 6.5.6
- 6.5.7
- 6.5.8
- 6.5.9
- 6.5b1
- 6.6a1
- 6.6b1
- 6.6rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.6
Auf 6.6 aktualisieren
python-tornado Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.2.1-1ubuntu2
- 4.2.1-1ubuntu3
- 4.2.1-1ubuntu3.1
- 4.2.1-1ubuntu3.1+esm1
- 4.2.1-1ubuntu3.1+esm2
- 4.2.1-1ubuntu3.1+esm3
- 4.2.1-1ubuntu3.1+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.5.1-2.1~build2
- 4.5.2-1
- 4.5.3-1
- 4.5.3-1ubuntu0.1
- 4.5.3-1ubuntu0.2
- 4.5.3-1ubuntu0.2+esm1
- 4.5.3-1ubuntu0.2+esm2
- 4.5.3-1ubuntu0.2+esm3
- 4.5.3-1ubuntu0.2+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 5.1.1-4ubuntu1
- 5.1.1-4ubuntu5
- 6.0.3+really5.1.1-2
- 6.0.3+really5.1.1-2build1
- 6.0.3+really5.1.1-2build2
- 6.0.3+really5.1.1-3
- 6.0.3+really5.1.1-3ubuntu0.1~esm1
- 6.0.3+really5.1.1-3ubuntu0.1~esm3
- 6.0.3+really5.1.1-3ubuntu0.1~esm5
- 6.0.3+really5.1.1-3ubuntu0.1~esm7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 6.1.0-1build1
- 6.1.0-2
- 6.1.0-3
- 6.1.0-3build1
- 6.1.0-3ubuntu0.1~esm1
- 6.1.0-3ubuntu0.1~esm2
- 6.1.0-3ubuntu0.1~esm4
- 6.1.0-3ubuntu0.1~esm5
- 6.1.0-3ubuntu0.1~esm6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Ubuntu:24.04:LTS
- Softwareversionen
- 6.3.2-1
- 6.4.0-0ubuntu1
- 6.4.0-1
- 6.4.0-1build1
- 6.4.0-1ubuntu0.1
- 6.4.0-1ubuntu0.2
- 6.4.0-1ubuntu0.4
- 6.4.0-1ubuntu0.5
- 6.4.0-1ubuntu0.6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Ubuntu:26.10
- Softwareversionen
- 6.5.4-0.1
- 6.5.5-2
- 6.5.5-4
- 6.5.5-5
- 6.5.5-5ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-tornado Ubuntu:26.04:LTS
- Softwareversionen
- 6.4.2-3
- 6.5.2-3
- 6.5.4-0.1
- 6.5.4-0.1ubuntu0.1
- 6.5.4-0.1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-pcg2-g6cj-q92c
- https://github.com/tornadoweb/tornado/pull/3765
- https://github.com/tornadoweb/tornado/commit/1b7a1dc9f340f52de929852e8125aa12f25297c9
- https://github.com/tornadoweb/tornado/releases/tag/v6.6.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-116577