CVE-2026-116579
CVE-2026-116579 · Autobahn Python: permessage-brotli inflates a whole frame before maxMessagePayloadSize is checked (incomplete fix of GHSA-hxp9-w8x3-p566)
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Autobahn Python is a WebSocket and WAMP implementation for Python that supports Twisted and asyncio. From 26.7.1 until 26.10.1, PerMessageBrotli.decompress_message_data in compress_brotli.py calls the Brotli decompressor without an output limit and checks maxMessagePayloadSize only after a complete frame has been inflated. An unauthenticated WebSocket client can send a small, highly compressed frame that allocates hundreds of MiB before rejection, causing memory-exhaustion denial of service on servers that enable the opt-in permessage-brotli feature through the compress extra. Deflate and bzip2 already enforce the remaining output budget and are outside this residual vulnerability. This issue is fixed in version 26.10.1.
CVSS 5.9 · Mittel · EPSS 0,4% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
autobahn-python
- Softwareversionen
- >= 26.7.1, < 26.10.1: Betroffen
Keine Korrektur veröffentlicht
autobahn PyPI
- Softwareversionen
- 26.7.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 26.7.1, < 26.10.1
Auf 26.10.1 aktualisieren
python-autobahn Ubuntu:16.04:LTS
- Softwareversionen
- 0.10.3+dfsg1-2
- 0.10.3+dfsg1-3
- 0.10.3+dfsg1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-autobahn Ubuntu:18.04:LTS
- Softwareversionen
- 0.14.1+dfsg1-2ubuntu1
- 17.10.1+dfsg1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-autobahn Ubuntu:20.04:LTS
- Softwareversionen
- 17.10.1+dfsg1-5
- 17.10.1+dfsg1-6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-autobahn Ubuntu:22.04:LTS
- Softwareversionen
- 17.10.1+dfsg1-7
- 21.11.1+dfsg1-2
- 21.11.1+dfsg1-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-autobahn Ubuntu:24.04:LTS
- Softwareversionen
- 22.7.1+dfsg1-3
- 22.7.1+dfsg1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-autobahn Ubuntu:26.10
- Softwareversionen
- 24.4.2+dfsg1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-autobahn Ubuntu:26.04:LTS
- Softwareversionen
- 23.1.2+dfsg1-2
- 24.4.2+dfsg1-4
- 24.4.2+dfsg1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/crossbario/autobahn-python/security/advisories/GHSA-pjh6-c8mg-3x7m
- https://github.com/crossbario/autobahn-python/pull/1987
- https://github.com/crossbario/autobahn-python/commit/a41442bbee4f6126a8ce1bb892840124c24d16f1
- https://github.com/crossbario/autobahn-python/releases/tag/v26_10_1
- https://nvd.nist.gov/vuln/detail/CVE-2026-116579