CVE-2026-15972
CVE-2026-15972 · Unauthenticated denial of service via unbounded external gRPC connection acceptance
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Consul Community Edition and Consul Enterprise 1.13.0 through 2.0.2 are vulnerable to an unauthenticated denial of service through unbounded connection acceptance on the external gRPC listeners. A remote attacker may exhaust agent file descriptors, goroutines, and memory by opening many incomplete connections, potentially preventing legitimate clients from connecting. This vulnerability, CVE-2026-15972, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.
CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
consul
- Softwareversionen
- ≥ 1.13.0, < 2.0.3: Betroffen (semver)
Auf 2.0.3 aktualisieren
consul enterprise
- Softwareversionen
- ≥ 1.13.0, < 2.0.3: Betroffen; ≥ 1.21.17: Nicht betroffen; ≥ 1.22.11: Nicht betroffen (semver)
Auf 1.21.17 aktualisieren
consul Debian:11
- Softwareversionen
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:18.04:LTS
- Softwareversionen
- 0.6.4~dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:20.04:LTS
- Softwareversionen
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht