CVE-2026-19017
CVE-2026-19017 · Consul vulnerable to partial arbitrary file read via Vault Connect CA provider
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Consul Community Edition and Consul Enterprise 1.18.21 through 2.0.2 are vulnerable to a partial arbitrary file read when configured to use the Vault Connect CA provider with JWT or AppRole authentication. A privileged attacker with `operator:write` permission may direct Consul to read and forward credential files outside the intended scope, potentially leading to the exfiltration of sensitive secrets from the Consul server host. This vulnerability, CVE-2026-19017, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.
CVSS 6.8 · Mittel · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
consul
- Softwareversionen
- ≥ 1.18.21, < 2.0.3: Betroffen (semver)
Auf 2.0.3 aktualisieren
consul enterprise
- Softwareversionen
- ≥ 1.18.21, < 2.0.3: Betroffen; ≥ 1.21.17: Nicht betroffen; ≥ 1.22.11: Nicht betroffen (semver)
Auf 1.21.17 aktualisieren
consul Debian:11
- Softwareversionen
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:18.04:LTS
- Softwareversionen
- 0.6.4~dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:20.04:LTS
- Softwareversionen
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht