p PatchFirst

CVE-2026-22779

CVE-2026-22779 · BlackSheep ClientSession is vulnerable to CRLF injection

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

BlackSheep is an asynchronous web framework to build event based web applications with Python. Prior to 2.4.6, the HTTP Client implementation in BlackSheep is vulnerable to CRLF injection. Missing headers validation makes it possible for an attacker to modify the HTTP requests (e.g. insert a new header) or even create a new HTTP request. Exploitation requires developers to pass unsanitized user input directly into headers.The server part is not affected because BlackSheep delegates to an underlying ASGI server handling of response headers. This vulnerability is fixed in 2.4.6.

CVSS 6.3 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • blacksheep

    Softwareversionen
    • < 2.4.6: Betroffen

    Keine Korrektur veröffentlicht

  • blacksheep PyPI

    Softwareversionen
    • 0.0.1
    • 0.0.2
    • 0.0.4
    • 0.0.5
    • 0.0.6
    • 0.0.7
    • 0.0.9
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 0.2.0
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.7
    • 1.0.8
    • 1.0.9
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 1.2.10
    • 1.2.11
    • 1.2.12
    • 1.2.13
    • 1.2.14
    • 1.2.15
    • 1.2.16
    • 1.2.17
    • 1.2.18
    • 1.2.19
    • 1.2.2
    • 1.2.20
    • 1.2.3
    • 1.2.4
    • 1.2.5
    • 1.2.6
    • 1.2.7
    • 1.2.8
    • 1.2.9
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • 2.0.8
    • 2.0a0
    • 2.0a1
    • 2.0a10
    • 2.0a11
    • 2.0a12
    • 2.0a2
    • 2.0a3
    • 2.0a4
    • 2.0a5
    • 2.0a6
    • 2.0a7
    • 2.0a8
    • 2.0a9
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.3.1
    • 2.3.1a1
    • 2.3.2
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.4a0
    • 2.4.4a2
    • 2.4.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.6

    Auf 2.4.6 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →