p PatchFirst

CVE-2026-22871

CVE-2026-22871 · GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, there is a path traversal vulnerability exists in GuardDog's safe_extract() function that allows malicious PyPI packages to write arbitrary files outside the intended extraction directory, leading to Arbitrary File Overwrite and Remote Code Execution on systems running GuardDog. This vulnerability is fixed in 2.7.1.

CVSS 8.7 · Hoch · EPSS 1,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • guarddog

    Softwareversionen
    • < 2.7.1: Betroffen

    Keine Korrektur veröffentlicht

  • guarddog PyPI

    Softwareversionen
    • 0.1.1
    • 0.1.10
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.11.1
    • 1.11.2
    • 1.2
    • 1.2.1
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.5.5
    • 1.5.6
    • 1.5.7
    • 1.5.8
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    • 1.8.2
    • 1.9.0
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.6.0
    • 2.7.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.7.1

    Auf 2.7.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →